Closed Bug 622319 Opened 12 years ago Closed 12 years ago

"ASSERTION: SHEntry already contains viewer" with reload()

Categories

(Core :: DOM: Navigation, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

Details

(Keywords: assertion, testcase)

Attachments

(2 files)

Attached file testcase
###!!! ASSERTION: SHEntry already contains viewer: '!aViewer || !mContentViewer', file docshell/shistory/src/nsSHEntry.cpp, line 240

Later, during cycle collection:

###!!! ASSERTION: User did not call nsIContentViewer::Destroy: '!mPresShell && !mPresContext', file layout/base/nsDocumentViewer.cpp, line 588
Attached file stack traces
(Not a regression)
WFM.  Maybe this was fixed by smaug's patch in bug 622480?
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Probably, since the testcase has javascript: url.
You need to log in before you can comment on or make changes to this bug.