Closed Bug 622343 Opened 9 years ago Closed 8 years ago

Junk icon is missing its description text in the customize menu

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 9.0

People

(Reporter: Nomis101, Assigned: tymerkaev)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image Screenshot of the issue
If you open the standalone window to read a mail than the junk icon in the customize menu dialog is missing its text.

STR:
1. Open a message in the standalone message window
2. Be sure that you have no Junk button, so the junk icon will be in the customize dialog
3. Open the customize dialog --> The Junk icon has no text
This works for me in 3.1.7. What version are you using?
Oh sorry, missed to mention the version. I see this on trunk builds, for me its currently:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9pre) Gecko/20110101 Thunderbird/3.3a2pre
I see this too. I don't have time to get a regression range, but it's somewhere between August 1 and October 1.
Thanks, that was helpfull to find a better regression range:

Gecko/20100804 - works
Gecko/20100806 - broken
Attachment #500816 - Flags: review? → review?(nisses.mail)
Comment on attachment 500816 [details] [diff] [review]
add missing titles for junk and delete decks

So, I mostly like this patch, but it doesn't work for me (as you can see in the following screenshot), so I'm going to have to r- it.

(I'm on Mac OS X 10.6.5.)

Thanks,
Blake.
Attachment #500816 - Flags: review?(nisses.mail) → review-
Sorry about that.  :(
Duplicate of this bug: 632533
(In reply to comment #8)
> Comment on attachment 500816 [details] [diff] [review] [review]
> add missing titles for junk and delete decks
> 
> So, I mostly like this patch, but it doesn't work for me (as you can see in
> the following screenshot), so I'm going to have to r- it.

This works for me on Linux (ok, to be fair, I just manually changed things instead of applying the patch). Maybe Mac has a bug somewhere deeper, e.g. in toolkit?
> I'm not seeing anything obvious here :(
Look again at the mozilla-central pushlog.


14a434e46cce	Markus Stange — Bug 580957 - Inside the toolbar customization panel the labels of the back/forward buttons and of the bookmarks menu button should be outside the button. r=dao

I think this line is the "problem"
http://hg.mozilla.org/mozilla-central/rev/14a434e46cce#l3.11

Blake, did you try the patch in safe-mode without any extensions enabled?
windows also
Philip: Probably not, but since it looks like you've found the source of the problem, would it really help if I did?
Well Blake, the patch should work. Since it isn't working for you how are you going to review/approve it?
Good question.  I tried it again, on a new profile, in safe mode, but it still didn't work, but I had a problem re-building before that, so it might not have picked it up.

I'll fire off a try-server build, and give that a test tomorrow, and see if I can replicate the problem and ensure that the patch fixes it.

Later,
Blake.
Attached image Patch works for me
Interestingly, for me the current patch from Azat works, tested on OS X 10.7. But do we really need the description two times? With this patch we than have junkItem.title and junkButton.label, which is both "Junk".

(In reply to comment #12) 
> I think this line is the "problem"
> http://hg.mozilla.org/mozilla-central/rev/14a434e46cce#l3.11
Are you sure, isn't this line Firefox-only? Its in browser.
> Are you sure, isn't this line Firefox-only? Its in browser.

/toolkit/content/customizeToolbar.css

Toolkit is shared code used by Firefox, SeaMonkey, and Thunderbird.
(In reply to comment #17)
> Interestingly, for me the current patch from Azat works, tested on OS X
> 10.7. But do we really need the description two times? With this patch we
> than have junkItem.title and junkButton.label, which is both "Junk".

It's conceivable that some locale might want to make junkItem.title something like "Delete/Undelete". That said, I'm not sure any locale would *actually* want this.
(In reply to comment #18)
> > Are you sure, isn't this line Firefox-only? Its in browser.
> 
> /toolkit/content/customizeToolbar.css
> 
> Toolkit is shared code used by Firefox, SeaMonkey, and Thunderbird.

Ah OK, you mean the toolkit part. Sorry, I didn't see the toolkit part yesterday...
Now I see what you mean and I absolutely agree with you (in all points)!
Comment on attachment 500816 [details] [diff] [review]
add missing titles for junk and delete decks

Okay, I _finally_ got Thunderbird compiling on Lion, and gave this patch a test, and it fixed the bug on my system.

Since there's nothing else I can see wrong with the patch, r=me.

Thank you, and I apologize for it taking so long.
Attachment #500816 - Flags: review- → review+
Is this bug ready to land? If so, please add checkin-needed.
Keywords: checkin-needed
Assignee: nobody → tymerkaev
Status: NEW → ASSIGNED
Hi,

Thanks for the patch! I just committed it and it should be in Thunderbird 9. In the future, what would make my life easier is the instructions outlined in there http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed ; I just committed 11 patches and, that's a lot of work :-).

Azat: I noticed you set r? without asking a person in particular. If you do that there's good chances the bug will fall into oblivion. You need to find a person suitable for reviewing your patch, and put their email address in the field. The list of contributors listed at the top of the file is usually a good start. If you've got a doubt, feel free to come over irc.mozilla.org#maildev

http://hg.mozilla.org/comm-central/rev/713a3036a6a9
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
Duplicate of this bug: 685182
Duplicate of this bug: 691134
You need to log in before you can comment on or make changes to this bug.