"ASSERTION: Must have a principal!"

NEW
Unassigned

Status

()

Core
DOM
7 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion})

Trunk
x86
Mac OS X
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Created attachment 500624 [details]
stack trace

###!!! ASSERTION: Must have a principal!: 'mOwner', file netwerk/protocol/wyciwyg/nsWyciwygChannel.cpp, line 279

Any idea what's going on here?
Not given just that stack.  Do we have anything resembling a testcase, even a non-minimal one?
(Reporter)

Comment 2

7 years ago
Not yet :(

Thanks, bz.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

7 years ago
With a bunch of help from bz, I figured out enough about this bug to make a testcase!
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
(Reporter)

Comment 4

7 years ago
Created attachment 501139 [details] [diff] [review]
patch for debugging
(Reporter)

Comment 5

7 years ago
Created attachment 501141 [details]
testcase (place in ~ and enable popups)
(Reporter)

Comment 6

7 years ago
Created attachment 501143 [details]
stack traces

"ASSERTION: Chrome trying to load wyciwyg URI" fires before "ASSERTION: Must have a principal!".
Attachment #500624 - Attachment is obsolete: true
(Reporter)

Comment 7

7 years ago
The problem seems to be useDefaultIcon assuming that if a document is an ImageDocument, then its URL is sane.

http://hg.mozilla.org/mozilla-central/annotate/969691cfe40e/browser/base/content/tabbrowser.xml#l677
Hmm.  Perhaps we should make document.write fail on ImageDocuments.
(Reporter)

Comment 9

7 years ago
I guess that would fix bug 622778, too.
(Reporter)

Updated

7 years ago
Status: REOPENED → NEW
(In reply to comment #8)
> Hmm.  Perhaps we should make document.write fail on ImageDocuments.
Yes.

Are there other features we should disable on ImageDocuments?
You need to log in before you can comment on or make changes to this bug.