"Do this automatically for files like this from now on" doesn't work with .torrent files which should open in uTorrent

RESOLVED DUPLICATE of bug 453455

Status

()

Firefox
File Handling
--
minor
RESOLVED DUPLICATE of bug 453455
8 years ago
7 years ago

People

(Reporter: peter.mx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

"Do this automatically for files like this from now on" doesn't work with .torrent files which should open in uTorrent.

Reproducible: Always

Steps to Reproduce:
1. Download .torrent and set "Do this automatically for files like this from now on" or set this under "Applications" tab in Options.
2. Download another torrent
Actual Results:  
"Opening torrent" window appears and you have to press OK for torrent to be downloaded and opened in uTorrent.

Expected Results:  
The window should not appear and .torrent should be downloaded and opened automatically.

I have tested this on multiple FF versions and multiple Windows OSes (x86 and x64), but I am not sure if the bug is related to uTorrent (I have not tested this with other torrent clients). Other file types, such as pdf, zip, doc, etc. work fine and open in proper application.

Comment 1

8 years ago
Tha depends on the URL :

- it it uses the "content-disposition: attachment" header, see bug 453455 comment 18
- if it uses the text/plain content-type, the webserver is misconfigured
- if it uses the application/octet-stream content-type, it's invalid, as the browser doesn't know what type it is, even though the OS might know how to open (Firefox doesn't the file-extension to make these decision).

Comment 2

7 years ago
Closing as incomplete. Need an exact url to do anything with this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE

Comment 4

7 years ago
This is because the server is sending "Content-Disposition: attachment;" 

http://tfile.ru/forum/download.php?id=383766&captcha=%F4%E4%EB%FF%E0

GET /forum/download.php?id=383766&captcha=%F4%E4%EB%FF%E0 HTTP/1.1
Host: tfile.ru
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Connection: keep-alive
Referer: http://tfile.ru/forum/download.php?id=383766&captcha=e%E4%F4%E7%E7
Cookie: JSESSIONID=43a35f54663efff412ef6e8d1346

HTTP/1.1 200 OK
Server: nginx
Date: Mon, 17 Jan 2011 13:41:50 GMT
Content-Type: application/x-bittorrent
Transfer-Encoding: chunked
Connection: keep-alive
X-Powered-By: Servlet/2.5
Set-Cookie: dtl=4d3449d101; Domain=.tfile.ru; Expires=Wed, 16-Feb-2011 13:53:21 GMT; Path=/
Content-Disposition: attachment; filename="Vtorzhenie_Bitva_za_raj_[tfile.ru].torrent"
Content-Encoding: gzip
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 453455
You need to log in before you can comment on or make changes to this bug.