Navigation and Personal toolbars not visible

RESOLVED INCOMPLETE

Status

P3
normal
RESOLVED INCOMPLETE
18 years ago
2 years ago

People

(Reporter: nick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; 0.6) Gecko/20001206
BuildID:    Mozilla/5.0 (Macintosh; N; PPC; en-US; 0.6) Gecko/20001206

The Navigation and Personal toolbars do not appear on my machine. Checking and
unchecking the options in the View:Toolbars menu does nothing. This has been the
case with every build of Mozilla or Netscape 6 I've used.

Reproducible: Always
Steps to Reproduce:
1. Remove all vestiges of older Mozilla or Netscape 6 builds.
2. Full install and launch browser.

Actual Results:  The Navigation and Personal toolbars do not appear.


Expected Results:  Navigation and Personal toolbars
 should always be visible when their options are checked in the View:Toolbars menu.

The "Taskbar" toolbar works fine. Unchecking the Taskbar menu option in
View:Toolbars causes it to disappear, as expected.
(Reporter)

Comment 1

18 years ago
Created attachment 20302 [details]
Screenshot showing menu selections & missing toolbars

Comment 2

18 years ago
Did you try removing your profile and are you sure you uninstall everything 
(mozregistry.dat, mozver.dat, other stuff) before installing new nightlies?
This seems like a bug in your profile, because this hasn't been reported before.
Thank you,
Fabian.
Summary: Navigation and Personal toolbars not visible → Navigation and Personal toolbars not visible

Comment 3

18 years ago
What skin is that?
URL: N/A
(Reporter)

Comment 4

18 years ago
I've removed everything I can find which is referenced by Mozilla. I was unable to find any 

.dat files which fit this description, however. The entire user profile folder has been trashed 

anlong with "Mozilla Registry" and "Mozilla Versions" from the Preferences folder.
(Reporter)

Comment 5

18 years ago
Okay, it seems to be a problem importing Preferences from Netscape 4. When I
created a new profile the toolbars appeared. Should I create a new bug based on
that information or should this one be left open?

Comment 6

18 years ago
That looks like the Orbit theme. Creating new profiles in third-party themes is
known to cause crashes, but I haven't seen anything like this. Seems to be a
theme problem, unless it can be reproduced with the default skins (Modern &
Classic).
(Reporter)

Comment 7

18 years ago
It is definitely NOT a theme problem. The problem stems from an issue with 

importing profiles from Netscape 4 preferences. The problem is reproducible every 

time using my current Netscape 4 profile.



Would someone like to look at it to determine if there are additional problems 

with importing? I'm still not sure if I should report this as a different (new) 

bug.

Comment 8

18 years ago
Nick, so this only with a migrated profile?  Have you tried creating another 4.x
profile and migrating it to see if it is specific to that profile or the more
general case of any migration causing the problem?  I don't see this problem
with new or migrated profiles on 121112 Mac builds.
(Reporter)

Comment 9

18 years ago
It appear that the problem only occurs with this specific profile. Importing a
fresh Netscape 4 profile does not cause the problem. The affected profile works
fine under Netscape 4, however. It's possible that other people will run into
the same issue if the root cause of the profile's corruption is common...

Comment 10

18 years ago
over to profile migration.
Assignee: asa → dbragg
Status: UNCONFIRMED → NEW
Component: Browser-General → Profile Migration
Ever confirmed: true
QA Contact: doronr → gbush

Comment 11

18 years ago
I would mark this worksforme because we cannot take into account each and every 
failure of the profile migration process. I have seen a lot of errors pertaining 
to migrated profiles and none of them were the same (except the localstore.rdf 
bug). If you can no longer reproduce then clearly your profile was corrupted at 
some point and I don't think the profile folks will be able to do anything about 
it. Please check your localstore.rdf file (in the 4.x profile) and see if it 
contains any garbage (strange characters). If it does, then it's a dup, if not, 
then i'll let the profile QA deal with it, but probably he can't do anything 
about it. :(
Thanks,
Fabian.

Comment 12

18 years ago
I've had the same problem ever since I tried the first Preview Release of
Netscape 6.  I run W98 though.  Also, while the toolbars don't display in the
browser, they do display in mail.
Marcus mgr@acetank.com

Comment 13

17 years ago
Reassigning profile migration bugs to the current owner
Assignee: dbragg → racham

Comment 14

16 years ago
I had the same problem with Mozilla 1.2 on Windows 98. But deleting the 
appropriate files as mentioned in a post below did the trick. It's definitely a 
problem with old Netscape profiles.

Comment 15

16 years ago
With Mozilla 1.2.1, the personal toolbar also does not show on
my Windows XP SP1 machine (P4, 512MB). "View set" for the personal
toolbar bookmark folder has no effect. The personal toolbar shows
fine on my Windows 2000 SP6 machine with the same Mozilla 1.2.1.
Reinstalling Mozilla 1.2.1 on the Windows XP SP1 machine did not
help, nor did anything else that I tried. The personal toolbar 
*content* shows up fine in the bookmarks manager, but like I said,
View-set to make it appear on the personal toolbar does nothing.
mass re-assign.
Assignee: racham → sspitzer
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Updated

15 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All

Comment 18

15 years ago
I have a similar  issue but only the navigation bar does not appear.
I reintalled firefox .8 several times , I always have the same issue.
I run XP home.
Netscape 7.1 and IE 6 work just fine

b2rtch@hotmail.com
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
QA Contact: agracebush → profile-migration

Comment 20

3 years ago
This bug is filed in a bugzilla component related to pre-Firefox code which no longer exists. I believe it is no longer relevant and I am therefore closing it INCOMPLETE.

If you believe that this bug is still valid and needs to be fixed, please reopen it and move it to the Toolkit:Startup and Profile System product/component.
No longer blocks: 1243899
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.