Status

()

Firefox
Extension Compatibility
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Aaron Digulla, Unassigned)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

Since FF 4.0b7, FF has Alzheimer. Sometimes, the icon won't show up in the status bar. Sometimes, the add-on isn't listed anymore on the add-ons page. Or the toolbar of the add-on is suddenly empty (Web Developer).

This happens both with compatible (Adblock plus, NoScript) and incompatible add-ons (Web Developer).

Reproducible: Sometimes

Steps to Reproduce:
- Start FF4 with "-no-remote -P"
- Create a new profile
- Start with the new profile
- Install "NoScript", "Adblock plus", "Add-on Compatibility Reporter"
- Restart
- Where is the NoScript icon? There is only a ABP button.
- Install "Web Developer"
- Restart
- What happened to the ABP button???
- And why is the toolbar of Web Developer empty?

Comment 1

8 years ago
Does this happen if you try with a clean profile and then add the addons again to that?
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
See step #3: "Start with the new profile"

Comment 3

8 years ago
Sorry missed that.

Using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110103 Firefox/4.0b9pre ID:20110103030359 and following comment 0 exactly...

- All addons show up at every stage in the addons manager (ie worksforme). 
- At the second to last step, the ABP button remains shown (ie worksforme).
- At the last step, the web developer toolbar isn't empty (ie worksforme).
- However I do also notice that the NoScript icon isn't present on the addon bar (ie this part confirmed, but see below). 

I suspect this is caused by NoScript itself not being changed to cater for the status bar having been replaced by the new addons bar in Firefox 4. However, NoScript is still present in the addons manager, so Firefox hasn't forgotten it entirely. Perhaps report the lack of addons-bar support to NoScript - and they can either fix the bug there or else if it turns out to be a problem with the new addon bar, they can report the necessary break on Bugzilla. 

The webdeveloper addon is also marked as not compatible with anything later than 3.6.x, so it's toolbar buttons being missing, might be due to that.

Perhaps try the latest nightly to see if the problem has been fixed since beta 8, explaining why I can't replicate it? NB: Please double check to see if it's just extensions missing from the addons bar or if they still are missing from the addons manager, which is an entirely different prospect altogether.
Keywords: regression
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> Sorry missed that.
> 
> Using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110103
> Firefox/4.0b9pre ID:20110103030359 and following comment 0 exactly...

I tried with Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre

> - All addons show up at every stage in the addons manager (ie worksforme). 
> - At the second to last step, the ABP button remains shown (ie worksforme).

I confirm; this seems to have been fixed in beta 9.

> - At the last step, the web developer toolbar isn't empty (ie worksforme).

Same here. Seems to work in beta 9 again.

> - However I do also notice that the NoScript icon isn't present on the addon
> bar (ie this part confirmed, but see below). 
> 
> I suspect this is caused by NoScript itself not being changed to cater for the
> status bar having been replaced by the new addons bar in Firefox 4. However,
> NoScript is still present in the addons manager, so Firefox hasn't forgotten it
> entirely. Perhaps report the lack of addons-bar support to NoScript - and they
> can either fix the bug there or else if it turns out to be a problem with the
> new addon bar, they can report the necessary break on Bugzilla. 

Will do. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 5

8 years ago
Thanks for confirming WFM.

Regarding NoScript, if it's any consolation I can't get it to show an icon in the new addons bar either. However, I personally prefer the addon bar hidden and have moved all icons I can into the normal toolbar, freeing up screen estate.

In the meantime, try:
Customise Toolbar -> Drag NoScipt icon to toolbar

(Also works with Adblock and a few others)
(Reporter)

Comment 6

8 years ago
Thanks for the tip, I'll try that. In the meantime, Giorgio Maone sent me in the right direction to get the icon back:

http://forums.informaction.com/viewtopic.php?f=7&t=5597&p=24559#p24559

In short: Delete the package mozilla-kde4-integration (I have openSUSE 1..3 and the package version was 0.6.2-1.9). After restarting FF, the icons show up again.
(Reporter)

Comment 7

8 years ago
I tried to move the NoScript icon with the "Customize Toolbar" but in there, I just have two buttons: "Temporarily allow all this page" and "Revoke Temporary Permissions". There is no ABP button at all.

So this doesn't work for me since I need the functions that the menus of the buttons in the add-on bar offer (like recently blocked sites).

Comment 8

8 years ago
Strange, I get the dropdown one as an option too...
You need to log in before you can comment on or make changes to this bug.