Firefox 4b8 fails to load CSS/JS for Google AdSense

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Julio Biason, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

It seems, for some reason, Firefox 4.0 beta 8 fails to load the CSS and JS of Google AdSense. The page loads only the text, but fails to display any layout, CSS or anything else.

The caches were clear. I opened the page for the first time since I got a new computer and it wouldn't display it properly. I cleared it afterwards anyway, but still no success.

I must admit, though, that I haven't checked if Google is doing User Agent sniffing and sending different content based on browser.

Reproducible: Always

Steps to Reproduce:
1. Log in with the Google Account that manages your AdSense.
2. Go to http://www.google.com/adsense

Actual Results:  
On Firefox, if you're already logged in, you'll see a cyan/gray screen. On any other browser, it shows the AdSense dashboard.

Similar effects happen on other pages: On Account Creation, the text is displayed, but no layout information is loaded. The JS also seems to fail to load, with some parts displaying only "true" or "false".

Expected Results:  
Page rendered properly.

Again, I haven't checked if it isn't Google doing User Agent sniffing and sending broken/incompatible data.
(Reporter)

Comment 1

7 years ago
I took a screenshot of a side-by-side comparison of the side in Firefox 4.0b8 and Safari. The starting URLs are the same, but it seems that, on Safari, additional information is loaded afterwards: http://i.imgur.com/6Qfa4.png

In this case, the URL was https://www.google.com/adsense/v3/app, already logged with an AdSense account.

Comment 2

7 years ago
Possibly due to Adblock Plus? (Seen in screenshot)

Could you see if the issue occurs with a new, empty profile:
http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_make-a-new-profile

Also, does it occur in the 3.6.13?
(Reporter)

Comment 3

7 years ago
OH $(deity)s!

/me bangs head on the desk.

Yes, it was AdBlock. Once I whitelisted the Google domain, everything went fine.

Needs a "RESOLVED - REPORTERISSTUPID" option, though.

/me keeps banging head on the desk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.