Drag & drop to Windows Explorer resulting in an empty file

RESOLVED FIXED

Status

()

Core
Widget: Win32
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: realname, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110103 Firefox/4.0b9pre SeaMonkey/2.1b2pre
Build Identifier: 

Drag & Drop of an image to Windows Explorer is resulting sometimes in an empty file.

Reproducible: Always

Steps to Reproduce:
Reproducible with e.g.: http://www.google.com/logos/
Don't affected by bug e.g.: http://de.docs.yahoo.com/info/

Try Google's site: Drag an image (like a doodle) to an opened Windows Explorer window. The file will be created with correct filename but WITHOUT content (empty, 0 bytes).

Try Yahoo's site: The file will be created correctly WITH content.

Maybee it's some difference in HTTP header which causes engine to fail?



Could be reproduced in SeaMonkey nightly (20110103), Firefox (4b7) and Thunderbird 3.1.7 - seems to be in Gecko. Because it's not for all http servers it's no bug in Windows?

Should be fixed fast because many users wouldn't see that the column "size" is empty. Or if they use a simple icon view in Win Explorer they don't see they saved a empty file.

Comment 1

7 years ago
works for me in winXP but I don't have latest FF built

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20100106 Minefield/3.7a1pre (.NET CLR 3.5.30729)

I do have a later TB built. Not sure if this is a good test but subscribed to the logos feed of google and dragged an image to an explorer window without problems.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100504 Lightning/1.1a1pre Shredder/3.2a1pre
Component: Drag and Drop → Widget: Win32
QA Contact: drag-drop → win32
(Reporter)

Comment 2

7 years ago
Tested with a new installed Win 7 Prof x64 and

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

Same bug there.

I've tried something more and watched traffic with Wireshark. Maybee it's because Google delivers the images with Transfer-Encoding: chunked;?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

7 years ago
Confirmed using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110111 Firefox/4.0b10pre ID:20110111030357

Exists in 3.6 and as far back as (at least) 3.0.

Dragging the "Jan 10, 2011    Coming of Age Day - (Japan)" PNG from the Doodle page resulted in a 0 byte file, same for "Dec 23, 2010    Happy Holidays from Google 2010 - (Global)". However, some of the other logos worked fine every time.
Hardware: x86_64 → x86

Comment 4

7 years ago
Probably the same bug.
Depends on: 536256

Comment 5

6 years ago
This should be fixed now. If you still see this in nightlies please re-open.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.