unable to write the email to the inbox

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: sleema, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.16) Gecko/20101130 Firefox/3.5.16 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

Using Thunderbird 3.1.7 (latest)on Windows 98 SE w/earthlink POP ISP
email working just fine.  but, for unknown reasons, computer was slow so I did
a hard shutdown (power off and on) while email open.
Restarted computer. re-opened Thunderbird.  Tried to download new email and got
the "unable to write the email to the inbox" error.  
tried all already documented steps in 166111 and related links, all failed, so did my own workaround, details below

Reproducible: Always

Steps to Reproduce:
1.unclear. happened after hard shutdown and restart of my computer
2.
3.
Actual Results:  
unable to write the email to the inbox

Expected Results:  
should have been able to write the email

Tried to fix by compacting
inbox, repairing inbox, compacting all folders, by creating a new folder and
replacing inbox' contents with it (i.e. the "Real Fix" from
http://kb.mozillazine.org/Compacting_folders)
all failed.
tried to download the email to earthlink webmail then delete it from webmail
then retry downloading future new messages from thunderbird. still no success.
downloaded email to thunderbird on other computer, that worked, so ruled out
ISP issue.  but tried again on computer w/the issue and and it still failed
w/subject error message.

Finally worked around by
1)creating a brand new profile with empty Inbox
2)copying all email folders from old profile to the new profile, including a
separate folder containing messages from the corrupted inbox
2a)also copied over address book 
(2 and 2a done to save all my folders from the
corrupted "profile"). 
3)restarted thunderbird with this new profile and emails download just fine
successfully, and all past inbox messages are available - I even moved them
from the separate folder to the real Inbox and downloads continued to work

observations:
-creating and deleting and allowing a new Inbox folder to be created, even a
new empty one that is left empty, does not fix the problem in all cases.  In my
case there must have been some other corrupted information somewhere in the
profile directory that is not purged unless a whole new profile is created
-copying folders from old profile to new profile works well - no messages were
lost
-this bug, technically, is not resolved nor fixed
-also has nothing to do with ISP or certain type of message header in this case

--may be important: when early in the process I copied my Inbox containing "10"
messages to a backup folder, when the copy completed it actually said it copied
"18" messages.  so somehow the message counter was getting updated even though
the "unable to write email to inbox" message was displaying

bottom line - 
-this bug, technically, is not resolved nor fixed ... would like to have at
least a more detailed error message explaining what is the real reason the mail
was not retrievable
-would like a built-in recovery procedure to avoid need to make a whole new
profile
-set at major severity only due to fact it is unclear how pervasive this is since trigger is unknown, if this is extremely rare to encounter, then lower to normal severity
(Reporter)

Comment 1

8 years ago
added daneel@rootshell.be  to cc: list since he apparently also fixed this issue a few years back by recreating the profile.. so points to a need to better understand what truly is corrupt. 
I do have the old corrupted profile backed up still, but Im not sure what file to send that would be of use, as I would not send my actual emails.  advise if a particular file would assist..
- is "unable to write the email to the inbox" the exact wording and spelling?
- Do you also see this issue when using version 5?
Summary: unable to write the email to the inbox; opening as new since duplicate bug 166111 is already marked resolved fixed but it is not → unable to write the email to the inbox
sleema, please, could you answer to comment #2?
Whiteboard: [closeme 2012-01-11]
(Reporter)

Comment 4

7 years ago
(In reply to Wayne Mery (:wsmwk) from comment #2)
> - is "unable to write the email to the inbox" the exact wording and spelling?

Yes
> - Do you also see this issue when using version 5?
I do not plan to try to recreate this on v5
=>WFM per comment #4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2012-01-11]
You need to log in before you can comment on or make changes to this bug.