All users were logged out of Bugzilla on October 13th, 2018

Browser suddenly jumps to another part of the web page after scrolling

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: sfid, Assigned: saari)

Tracking

Trunk
mozilla1.0
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001206
BuildID:    2000120604

At this web page, if one scrolls to the bottom, follows a link and then go back,
scrolling does not work properly.

Reproducible: Always
Steps to Reproduce:
1. Scroll to bottom of page with the mouse
2. Push the "Privacy Statement" link
3. Wait for the page to load
4. Go back
5. Scroll upwards with the mouse


Actual Results:  The scrollbar suddenly jumps to another place on the page




Expected Results:  The scrollbar does not jump to another place on the page



PS. This does not happen when scrolling using the keyboard.

Comment 1

18 years ago
Works for me using 20000120804 on WinME with logitech mouse
(Reporter)

Comment 2

18 years ago
I've still got the problem with 20001211. Intellimouse on Win98 SE.
I see this problem with build 2000120404. It happens when you scroll up with the
scrollbar, or scrollwheel, but not with the keyboard

I think the rational behind it was that when you go back, you want to go back to
the part of the page you last looked at (in my experience, this is generally
what I want to do). As a result, it scrolls the view the same area of the page
as it was orginally viewing, after waiting a bit to make sure that part of the
page has loaded. I think this behaviour should be modified so that if the user
has scrolled the view after the back button was pressed, it wouldn't try to move
the view around.
I can reproduce the bug, linux build 2000-12-05-08. Indeed, one needs to scroll
up before the page is fully loaded to see this bug.  Assigning to history since
that's where all the "back button scrolling" bugs seem to be.
Assignee: joki → radha
Status: UNCONFIRMED → NEW
Component: Event Handling → History
Ever confirmed: true
OS: Windows 98 → All
QA Contact: lorca → claudius

Comment 5

18 years ago
I'd say that maybe scrolling should be linked to a onLoad handler-that would 
prevent this issue from occuring.  This was the same solution found to "Problem 
navigating to different page using Anchors" or something like that...My $0.02.
nav triage: dup of 36539

*** This bug has been marked as a duplicate of 36539 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Since this bug has a bt more info, I'm making the other a dup.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

18 years ago
*** Bug 36539 has been marked as a duplicate of this bug. ***
Mass moving all Navigator bugs to the Nav team. 
Assignee: radha → vishy
Status: REOPENED → NEW
*** Bug 69127 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
alecf
Assignee: vishy → alecf

Comment 12

18 years ago
cc Eric who fixed some bugs awhile back that dealt with scrolling the view after using the
back button.

Comment 13

18 years ago
this is some focus wierdness.. bites me all the time, reassign to saari the
focus dude.
Assignee: alecf → saari

Comment 14

18 years ago
CC'ing Eric - know anything about why this might happen?
(Assignee)

Comment 15

18 years ago
Another example of focus suppression regressing
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9

Comment 16

18 years ago
->hyatt
Assignee: saari → hyatt
Status: ASSIGNED → NEW

Comment 17

18 years ago
I cannot reproduce this bug.  Could QA test the original URL and see if they can
reproduce this bug?

Comment 18

18 years ago
worksforme, win2k 2001041015.

Comment 19

18 years ago
the key to this bug seems to be scrolling before the page finished loading. Then we'd check
to see where your old view was and move you there- which was the offending behavior.
Well I don't have a mousewheel to try, but with the mouse and the scroll thumb this is pretty
much impossible to repro. At the above url,
I can grab the scroll thumb and move the mouse before the page loads but I never get any
UI repsonse (scroll view, redraw thumb) until after the page finishes laoding. (which only takes
a split second)

I couldn't see it on any other pages either but I'd need a real slow page to be sure...

Comment 20

18 years ago
->moz0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1

Comment 21

18 years ago
> the key to this bug seems to be scrolling before the page finished loading.
> Then we'd check to see where your old view was and move you there- which was
> the offending behavior.

This happens to me pretty often on long pages that didn't completely load the
first time (mailing list archives and such). What happens is that it seems to
jump to your previous position in the page every time data comes in, and without
checking to see if you've manually scrolled around since clicking back.

> Well I don't have a mousewheel to try, but with the mouse and the scroll thumb
> this is pretty much impossible to repro. At the above url, I can grab the
> scroll thumb and move the mouse before the page loads but I never get any
> UI repsonse (scroll view, redraw thumb) until after the page finishes laoding.
> (which only takes a split second)

Try viewing a large page and clicking on a link before the whole thing loads,
then going back. A slow/saturated link helps.

Comment 22

18 years ago
--> saari
Assignee: hyatt → saari

Updated

18 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.3
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9.3 → mozilla1.0

Comment 23

17 years ago
Marking as WFM because I've seen this bug in the time when it was reported, but
now I couldn't reproduce it for a long time. (For at least 1 month.)
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.