check hg account Robert Brand <mozrob@googlemail.com>: pushing to l10n-central fails

VERIFIED FIXED

Status

VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: mozilla, Assigned: jlaz)

Tracking

Details

(Reporter)

Description

8 years ago
Could you please check my hg account (was created with bug 478953 and bug 480216), because since ~late december I can't push to l10n-central/de anymore:
$ hg push
pushing to ssh://hg.mozilla.org/l10n-central/de/
searching for changes
remote: adding changesets
remote: abort: Permission denied: /repo/hg/mozilla/l10n-central/de/.hg/store/00changelog.i
abort: unexpected response: empty string

My last push to l10n-central was http://hg.mozilla.org/l10n-central/de/pushloghtml?changeset=f6ab8d6e0f0f.
Pushing to /l10n-mozilla-1.9.2/de/ still works for me.
Robert, could you clarify on what you mean by "pushing to 1.9.2 still works for me"? As in, your latest push that I can see was on the repo that doesn't work no more.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Robert, could you clarify on what you mean by "pushing to 1.9.2 still works for
> me"? As in, your latest push that I can see was on the repo that doesn't work
> no more.

On 2010-12-30 I pushed this one to /l10n-mozilla-1.9.2/de:
http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/de/rev/a89727d8227b
Another push to that repo was on 2010-12-03.

That's confusing me: one setup, two repos, but only one repo (l10n-central/de) fails.
Looks like this was missing the scm_level_1 bit, which I just flipped.  Should work now
Assignee: server-ops → jlazaro
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
To clarify:

The permission bit should be scm_l10n for localizers, at least that's what my mental notes say. That doesn't imply scm_level_1, but needs it explicitly set?
From what I was told, scm_level_1 is required along with scm_l10n
(Reporter)

Comment 6

8 years ago
Verified fixed. Thanks for taking care!
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.