Whole page in English if article not translated into another language

RESOLVED DUPLICATE of bug 622151

Status

support.mozilla.org
Knowledge Base Software
RESOLVED DUPLICATE of bug 622151
7 years ago
7 years ago

People

(Reporter: Thomas Schwecherl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
If an article is not translated then the whole page (incl. header, footer, and sidebars) is shown in English and not in the language of the browser.

E.g. if you are a German speaking user and if you want to open page https://support.mozilla.com/kb/add-a-device-to-firefox-sync or page https://support.mozilla.com/kb/templateadddevices then you will be redirected to the English page incl. English header, English sidebars, links to other English pages, etc.

Expected behavior:
Not yet localized pages should be shown in the language of the user and only the _article text_ should be in English.



HTTP header for https://support.mozilla.com/kb/add-a-device-to-firefox-sync:

https://support.mozilla.com/en-US/kb/add-a-device-to-firefox-sync#os=linux&browser=fx35


GET /en-US/kb/add-a-device-to-firefox-sync HTTP/1.1

Host: support.mozilla.com

User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

Accept-Language: de-at,de-de;q=0.8,de;q=0.7,en-gb;q=0.5,en-us;q=0.3,en;q=0.2

Accept-Encoding: gzip,deflate

Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 622151
You need to log in before you can comment on or make changes to this bug.