quick filter field on the message list lost its boolean support in v3; worked in v2

RESOLVED DUPLICATE of bug 586131

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 586131
7 years ago
6 years ago

People

(Reporter: Anthony DiSante, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.5.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101208 Thunderbird/3.1.7

In Thunderbird v2, in the "Filter these messages" field, when you entered "foo|bar" it would show messages matching either "foo" or "bar".  In v3, it doesn't; it treats the pipe/vertical-bar as a literal part of the search string, so no messages are matched.

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Updated

6 years ago
Summary: Filter field on the message list lost its boolean support in v3; worked in v2 → quick filter field on the message list lost its boolean support in v3; worked in v2
Whiteboard: dupeme

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 586131
You need to log in before you can comment on or make changes to this bug.