Firefox does not start and issues misleading message when default profile folder does not exists

RESOLVED DUPLICATE of bug 278860

Status

()

Toolkit
Startup and Profile System
RESOLVED DUPLICATE of bug 278860
7 years ago
4 years ago

People

(Reporter: Ben, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

I stumbled upon this when doing an other test.

If the current profile folder does not exist then firefox would not start, it would issue an error "Firefox is already running, but is not responding. to open a new window you must first close the existing Firefox process or restart your system".

However restarting the system does not help and the only way out is to start firefox with profile manager and create an other profile.


Reproducible: Always

Steps to Reproduce:
1. Launch firefox with option -P and create new profile named Test (any name would be ok)
2. Use about:support and click on Profile directory->"open containing folder"
3. Quit Firefox.
4. Navigate one directory up the profile folder and Delete the Test profile folder.
5. Launch Firefox with no options.
6. Firefox issues an error dialog "Firefox is already running, but is not responding..."
7. Rebooting your computer does not help.
Actual Results:  
Firefox does not start. No easy way out this !

Expected Results:  
Firefox should issue an error and likely start the profile manager to let the user either select an existing profile or create a new one.

Note that when using the profile manager and selecting the profile whose directory has been deleted will also cause a misleading error.

I classify it as major because the user has no easy & documented recovery path.
Severity: major → normal
Component: General → Startup and Profile System
Product: Firefox → Toolkit
QA Contact: general → startup
Whiteboard: dupeme
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278860

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.