gtk_widget_has_focus does not work for checkboxes or radiobuttons

RESOLVED DUPLICATE of bug 622899

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 622899
8 years ago
8 years ago

People

(Reporter: Steven Eastland, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/534.13 (KHTML, like Gecko) Chrome/9.0.597.19 Safari/534.13
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

I am using the new oxygen-gtk GTK style, and checkbox and radio buttons do not have a focus rectangle being drawn.  I filed a bug at https://bugs.kde.org/show_bug.cgi?id=261985 and apparently the GTK gtk_widget_has_focus function is working for other widgets (buttons, comboboxes, etc.)

As explained in https://bugs.kde.org/show_bug.cgi?id=261985#c10, this behavior is preventing proper drawing of focus around the widget itself.

Reproducible: Always

Actual Results:  
No focus indicator is drawn for checkbox and radio widgets.

Expected Results:  
Focus indicator should be drawn on checkbox and radio widgets.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 622899
You need to log in before you can comment on or make changes to this bug.