Ctrl-F does not activate search in textarea

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: kdevel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

793 bytes, text/html
Details
(Reporter)

Description

8 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20100101 Firefox/4.0b9pre

Ctrl-F does not activate the search bar.

Reproducible: Always

Steps to Reproduce:
1. open testcase
2. press ctrl-f
3.
Actual Results:  
Cursor advances one position, search bar is not activated.

Expected Results:  
Cursor does not advance, search bar is activated.

Ctrl-G does activate the search bar (if there is no memorized search string).
(Reporter)

Updated

8 years ago
Summary: Ctrl-F does not aktivate search in textarea → Ctrl-F does not activate search in textarea
(Reporter)

Comment 1

8 years ago
Created attachment 501116 [details]
testcase

Comment 2

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20110104 Firefox/4.0b9pre

Works for me. Please try by creating a new profile and check if you are able to reproduce. 
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile.
(Reporter)

Comment 3

8 years ago
reproduced the issue with

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre
Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre
(Reporter)

Comment 4

8 years ago
It is Emacs keybindings:

http://kb.mozillazine.org/Emacs_Keybindings_%28Firefox%29

I think that binding ctrl-F to cursor movement (in input fields) is CORRECT. (like ctrl-u in location bar correctly erases its content instead of showing the page source).

Can sb close this bug?
(Reporter)

Comment 5

8 years ago
non-issue
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.