layout/generic/crashtests/348887-1.html fails in new reftest harness

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: cjones, Unassigned)

Tracking

({intermittent-failure, regression})

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(b2g-v2.5 fixed, fennec-)

Details

This test sets up its termination by doing

<head>
<script>
setTimeout('document.documentElement.className = ""', 1000);
</script>

This worked fine in the old reftest harness.  In the new one, both in- and out-of-process, the page's setTimeout() handler is never called and the test then iloops because the document-element class name is never removed.

If this handler is refactored to enqueue a setTimeout() of a function to remove the document-element attribute off of an onload handler, then it works fine.

Not sure what might be causing this.
Looks like something that could affect web content in fennec.
tracking-fennec: --- → ?
What is "old reftest harness" vs. "new reftest harness"?
New == "bug 615386", old == "m-c tip".  I'm not in a hurry to investigate this: it was the only reftest/crashtest affected in this way, is disabled for now, and obviously isn't breaking fennec on common sites.  I'm fine with waiting for bug 615386 to land so STR don't include grabbing a stack of patches.
tracking-fennec: ? → 2.0-

Updated

8 years ago
Blocks: 615386

Comment 4

8 years ago
This bug is also causing random orange (bug 655495, bug 662795). I am sad that this regression has been allowed to linger.
Blocks: 438871
Keywords: regression
Whiteboard: [orange]
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
Test runs without issue on trunk.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.