Flash crashes when reloading youtube since 2010/10/29

RESOLVED DUPLICATE of bug 617469

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 617469
7 years ago
7 years ago

People

(Reporter: Mardak, Assigned: BenWa)

Tracking

({crash, regression, reproducible})

Trunk
x86
Mac OS X
crash, regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [hardblocker])

(Reporter)

Description

7 years ago
I was tracking down a regression range for bug 590955 and ended up somewhere in the ~2010/04/05 range (when OOPP was first enabled for flash on os x), but I wasn't able to consistently determine a good build as it didn't always crash.

But I noticed that trunk crashes much more easily than those builds from april. So for a simpler STR, I just load a youtube page, e.g., http://www.youtube.com/watch?v=COU5T-Wafa4 and hit cmd-r to reload. And it'll crash pretty consistently. Make sure to run in 32bit mode if you want a crash report.

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fe4898e97431&tochange=799a83ba5f86

The crash reports are the same as those in bug 590955 (going all the way back to april too), but something in that pushlog caused flash to crash much easier. Perhaps bug 604734?
(Reporter)

Updated

7 years ago
blocking1.9.2: --- → ?
(Reporter)

Updated

7 years ago
blocking1.9.2: ? → ---
blocking2.0: --- → ?
Keywords: reproducible

Updated

7 years ago
Severity: normal → critical
(Assignee)

Comment 1

7 years ago
I found something suspicious, taking this to investigate.
Assignee: nobody → b56girard

Updated

7 years ago
blocking2.0: ? → betaN+
(Assignee)

Comment 2

7 years ago
So far what I have found is that Flash is calling ConvertPoint, however instead of getting a response the browser process called NPP_Destroy, then once the plugin process returns from ConvertPoint the plugin instance has been destroyed presumably causing a crash within flash.

I'll look why we are calling NPP_Destroy in the middle of a ConvertPoint RPC call.

Also commenting out the ConvertPoint RPC call in the plugin process makes the crash go away.

Test logging I used to diagnose the problem (May not be useful to others):
Calling Convert Point
cast instance 0x2459A8C
ndata = 0x2459A60
PARENT: CallNPP_Destroy();
Destroy instance 0x2459A8C
ndata = 0x0
Destroy plugin instance

###!!! [Parent][RPCChannel] Error: Route error: message sent to unknown actor ID

Convert Point return
cast instance 0x2459A8C
ndata = 0x0

Comment 3

7 years ago
I believe this is a dup of bug 572134.

Comment 4

7 years ago
And is also probably the same as bug 617469, although the stacks are different.

Comment 5

7 years ago
I'm pretty sure this is a dupe of bug 617469, the stacks are sometimes different when reproducing it in that the last call isn't always NPN_ConvertPoint.
Whiteboard: [hardblocker]

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 617469
You need to log in before you can comment on or make changes to this bug.