Much memory usage for a few loaded and dozens of not-loaded tabs

RESOLVED WORKSFORME

Status

()

Firefox
General
--
enhancement
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: nextwww, Unassigned)

Tracking

3.6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

I have dozens of tabs (about 500), and when I open the FF it tries to load it from the cache, so it takes a few minutes to become accessible. However, then I'm not connected and the majority of pages cannot be loaded as my cache isn't that big. When FF becomes available, I get connected and start using it. But the issue is that FF takes about 300MB of the memory for pages that simply have not loaded anything, and accordingly, it slows down. I wonder whether the FF could manage the tabs more efficiently, so that my space and time is not wasted.

Thank you.

Reproducible: Always

Steps to Reproduce:
1.Open FF (my cache-size is about 250)
2.Load it with a few hundred tabs addressed to some page
3.Close and save tabs
4.Disconnect
5.Open FF
Actual Results:  
Consuming much memory while a few of the hundreds of pages are actually loaded. Normal operation is slowed down.

Expected Results:  
Memory consumption and operation performance be linear to the amount of pages that actually are loaded.
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch
This decribed Behavior got improved in Firefox 4 Development.
http://www.mozilla.com/en-US/firefox/all-beta.html

Comment 2

6 years ago
As far as I know, memory usage for this and other use cases got drastically improved in the last few Firefox releases.  Resolving this bug for now; please reopen (or request reopening) if you still encounter excessive memory usage with current Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 3

6 years ago
My way of (ab)using firefox is keeping open the tabs that are interesting, and about once per month go through them and create relevant bookmarks and close them. But even though I enable "do not load tabs on startup" option, when I restart the browser it consumes more than 200MB with about 190 tabs. I attach some about:memory (very useful tool!) statistics from firefox 13a nightly.

Comment 4

6 years ago
Created attachment 596378 [details]
javascript memory usage with 190 not-loaded tabs

I suppose the 10MB about:blank compartment is related to the tabs that are not loaded. Is this really needed? Also the "system principal" compartment is way too large (50MB), I can't reproduce this with a clean session.

Comment 5

6 years ago
Created attachment 596381 [details]
layout memory usage

65MB heap-unclassified and 13.5MB layout data for identical blank pages.

Comment 6

6 years ago
Am I right thinking that the only things actually needed for each not-loaded tab are the title and the URL? Shouldn't all the other tab data be identical (i.e. blank) for all? Out of curiosity I measured the weight of a single about:blank page in a few tabs session:

javascript: 74K
│  ├──────74,360 B (00.08%) -- compartment(about:blank)
│  │      ├──65,536 B (00.07%) -- gc-heap
│  │      │  ├──42,120 B (00.04%) -- arena
│  │      │  │  ├──41,672 B (00.04%) ── unused
│  │      │  │  ├─────256 B (00.00%) ── headers
│  │      │  │  └─────192 B (00.00%) ── padding
│  │      │  ├──13,816 B (00.01%) -- shapes
│  │      │  │  ├───9,240 B (00.01%) ── tree
│  │      │  │  ├───4,192 B (00.00%) ── base
│  │      │  │  └─────384 B (00.00%) ── dict
│  │      │  ├───8,976 B (00.01%) -- objects
│  │      │  │   ├──7,712 B (00.01%) ── function
│  │      │  │   └──1,264 B (00.00%) ── non-function
│  │      │  ├─────480 B (00.00%) ── type-objects
│  │      │  └─────144 B (00.00%) ── scripts
layout: 158K
│   ├────157,968 B (00.16%) -- shell(about:blank)
│   │    ├──123,040 B (00.13%) ── styledata [2]
│   │    └───34,928 B (00.04%) ── arenas [2]
You need to log in before you can comment on or make changes to this bug.