Crash [@ js::mjit::EnableTraceHint ]

RESOLVED DUPLICATE of bug 606423

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 606423
8 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(crash signature)

(Reporter)

Description

8 years ago
It is #15 top crasher on Mac OS X in Firefox 4.0b8 for the last week.
It is #21 top crasher in Fennec 4.0b3 for the last week.

UUID	093af03c-3c84-4e4d-98e6-d68ca2110104
Frame 	Module 	Signature [Expand] 	Source
0 	XUL 	js::mjit::EnableTraceHint 	js/src/assembler/assembler/X86Assembler.h:2255
1 	XUL 	js::AttemptCompilation 	js/src/jstracer.cpp:1415
2 	XUL 	js::TraceRecorder::closeLoop 	js/src/jstracer.cpp:4913
3 	XUL 	js::TraceRecorder::checkTraceEnd 	js/src/jstracer.cpp:5398
4 	XUL 	js::TraceRecorder::relational 	js/src/jstracer.cpp:9100
5 	XUL 	js::TraceRecorder::monitorRecording 	js/src/jstracer.cpp:10514
6 	XUL 	js::Interpret 	js/src/jsinterp.cpp:2670
7 	XUL 	js::Invoke 	js/src/jsinterp.cpp:657
8 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
9 	XUL 	JS_CallFunctionValue 	js/src/jsinterp.h:962
10 	XUL 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1692
11 	XUL 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:588
12 	XUL 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_x86_64_darwin.cpp:153
13 	XUL 	XUL@0xe0112a 	
14 	XUL 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1114
15 	XUL 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1210
16 	XUL 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventListenerManager.h:146
17 	XUL 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:628
18 	XUL 	nsEventDispatcher::DispatchDOMEvent 	content/events/src/nsEventDispatcher.cpp:691
19 	XUL 	nsDocument::DispatchEvent 	content/base/src/nsDocument.cpp:6284
20 	XUL 	nsContentUtils::DispatchTrustedEvent 	content/base/src/nsContentUtils.cpp:3386
21 	XUL 	nsDocument::DispatchContentLoadedEvents 	content/base/src/nsDocument.cpp:4098
22 	XUL 	nsRunnableMethodImpl<void ,true>::Run 	nsThreadUtils.h:345
23 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:626
24 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:200
25 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:132
26 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:399
27 	CoreFoundation 	CoreFoundation@0x4e400 	
28 	CoreFoundation 	CoreFoundation@0x4c5f8 


UUID	d448bd29-c8f3-446d-b319-6e39e2110103
Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	js::mjit::EnableTraceHint 	js/src/assembler/assembler/ARMAssembler.h:981
1 	libxul.so 	js::LoopProfile::decide 	js/src/jstracer.cpp:1415
2 	libxul.so 	js::MonitorLoopEdge 	js/src/jstracer.cpp:16935
3 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:3076
4 	libxul.so 	js::MonitorTracePoint 	js/src/jstracer.cpp:16558
5 	libxul.so 	RunTracer 	js/src/methodjit/InvokeHelpers.cpp:988
6 	libxul.so 	js::mjit::stubs::InvokeTracer 	js/src/methodjit/InvokeHelpers.cpp:1075
7 	libxul.so 	libxul.so@0xae0396 	
8 	libxul.so 	js::mjit::stubs::InvokeTracer 	js/src/methodjit/InvokeHelpers.cpp:1073
9 	libxul.so 	js::mjit::JaegerShot 	js/src/jsinterp.h:576
10 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:654
11 	libxul.so 	js_fun_apply 	js/src/jsfun.cpp:2226
12 		@0x44d6ffb3 	
13 	libxul.so 	js::mjit::JaegerShot 	js/src/jsinterp.h:576
14 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:654
15 	libxul.so 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
16 	libxul.so 	JS_CallFunctionValue 	js/src/jsinterp.h:962
17 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2178
18 	libxul.so 	nsGlobalWindow::RunTimeout 	nsCOMPtr.h:888
19 	libxul.so 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9314
20 	libxul.so 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:426
21 	libxul.so 	nsTimerEvent::Run 	nsAutoPtr.h:969
22 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:626
23 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
24 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:111
25 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	ipc/glue/MessagePump.cpp:230
26 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:220
27 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:512
28 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:198
29 	libxul.so 	XRE_RunAppShell 	toolkit/xre/nsEmbedFunctions.cpp:631
30 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	ipc/glue/MessagePump.cpp:222
31 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:220
32 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:512
33 	libxul.so 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp:510
34 	libmozutils.so 	ChildProcessInit 	other-licenses/android/APKOpen.cpp:691
35 	plugin-container 	main 	ipc/app/MozillaRuntimeMainAndroid.cpp:69
36 	libc.so 	libc.so@0xd432 	

More reports at:
http://crash-stats.mozilla.com/report/list?range_value=4&range_unit=weeks&signature=js%3A%3Amjit%3A%3AEnableTraceHint
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
tracking-fennec: --- → ?
Likely a dup of bug 606423.
Yes, it looks like the Mac version of the same crash. The crash addresses are the same. And it goes away on 12/31, just like the other one.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 606423
blocking2.0: ? → betaN+
Crash Signature: [@ js::mjit::EnableTraceHint ]
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.