Table rendering problem

RESOLVED WORKSFORME

Status

()

P3
major
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: asreddy_74, Assigned: karnaze)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
The example below shows the problem.  The expected behaviour is the same as in
IE 5.0

<HTML>
<HEAD>
<TITLE>Table render problem</TITLE>
</HEAD>
<BODY>
<table style="background:#4F556A;"  border=0 cellspacing=0 cellpadding=0
width='400' >
<tr>
<td style="background:#4F556A;" >
<table border="0" cellspacing="1" cellpadding="0"  width='400' >
    <tr    >


              <td
style="background:#CDCDBE;font-family:arial,sans-serif;font-size:9pt;"  nowrap
rowspan='2' nowrap >&nbsp;&nbsp;

                row 1 column 1 rowspan 2
              &nbsp;&nbsp;</td>


            <td
style="background:#F5F4E7;font-family:arial,sans-serif;font-size:9pt;"  nowrap
align='right' nowrap >&nbsp;&nbsp;

             r1 c2
            &nbsp;&nbsp;</td>

            <td
style="background:#F5F4E7;font-family:arial,sans-serif;font-size:9pt;"  nowrap
nowrap >&nbsp;&nbsp;

              r1 c3
            &nbsp;&nbsp;</td>

          </tr>

          <tr    >


            <td
style="background:#CDCDBE;font-family:arial,sans-serif;font-size:9pt;"  nowrap
colspan='2' nowrap >&nbsp;&nbsp;

              r 2 c 2
            &nbsp;&nbsp;</td>

          </tr>



    </table></td></tr></table></BODY>
</HTML>
The HTML provided renders correctly as far as I can tell in linux build
2000-12-05-08.  Reporter, could you please provide us with more information,
such as your build id and see whether you can reproduce this with a recent
nightly build?

Also, if you can provide screenshots of a correct rendering and an incorrect
one, that would help a lot.

Comment 2

18 years ago
WMF, build 200120804 on WinNT4 Sp6b
Even if there are some errors in the HTML.
Are you using a DTD, and if so something like this??

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

And try validating your page at: http://validator.w3.org/check

Friendly, HJ.
(Reporter)

Comment 3

18 years ago
My build id is 20001108 (the updated Netscape 6 version) on WinNT4 sp5.  I have 
checked using DTD and validated the page (I had to make a few changes - ie 
remove repeated nowrap) but the problem persists.  The problem is that the 
table background color overflows and can be seen as thicker right border in 
this case.  Altering the width or increasing the content size solves the problem
I could test it on the latest build but would it be generally available soon?

Regards
Srinivas

Comment 4

18 years ago
Created attachment 20459 [details]
Attachment containg html tetcase with no modifications

Comment 5

18 years ago
Created attachment 20460 [details]
formatted and html validated version of html

Comment 6

18 years ago
I've just added the html as an attachment (helps ensure that everyone is looking
at the same html).
I've also added a formatted and html validated version of the original html.
Both attachments look the same to with in Mozilla 2000121008 in WinNT as in IE5.5

Comment 7

18 years ago
Reporter, now you see how important it is to explain exactly what you are
seeing, and what's wrong with that! I thinks, this is only a small cosmetic bug.
I will take a closer look, now I know where to look for!

Friendly, HJ.

Comment 8

18 years ago
Adding cc myself

Comment 9

18 years ago
Worksforme
Platform: PC
OS: Windows 98
Mozilla Build: 2000121804 M18 Trunk

Marking as such. Reopen if its still a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 10

18 years ago
Please take a closer look before closing this bug!

Comment 11

18 years ago
Created attachment 21031 [details]
For your eyes only

Comment 12

18 years ago
As you now ALL can see the first one is wrong!
The second one is taken out of Internet Explorer!
So, why is this invalid? Please clarify!
Did you not see this problem?
Friendly, HJ.

Comment 13

18 years ago
QA contact update
QA Contact: chrisd → amar
You need to log in before you can comment on or make changes to this bug.