[OGL] firefox hangs or has to be closed when the OpenGL display driver crashes

REOPENED
Unassigned

Status

()

REOPENED
8 years ago
7 years ago

People

(Reporter: blizzard, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Loading the ray tracer eventually crashes the NVIDIA driver on Windows 7.  I've seen two things happen:

1. I get the display driver crash and windows recovers.  Then Firefox is hung, and has to be killed.  It does not recover.

or

2. I get a dialog that says "The NVIDIA OpenGL Driver encountered an uncoverable error and must close this application.  Error 13"

Either way, bad mojo.  Joe says that Firefox should be able to recover from the failure.
Hrm, sadly on my NVidia devices/drivers this loads fine :(
This will be fixed when we use ANGLE for rendering WebGL. I'm not sure if we can easily get OpenGL to recover.
Summary: firefox hangs or has to be closed when the display driver crashes → [OGL] firefox hangs or has to be closed when the OpenGL display driver crashes
Sounds like we're going to avoid fixing this for now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
How does that make this bug invalid, exactly?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
When this bug was filed, using the OpenGL driver was our main way of rendering WebGL.

Now our main way is ANGLE/D3D, although we still use OpenGL on a few devices (Optimus) and would like to keep open the option to use it at least on other NVIDIA hardware.

Is this bug still reproducible?
OK, had a look at comment 0 this time :)

The URL doesn't crash recent versions of the nvidia driver. if it crashes some version that we don't blacklist, we can blacklist it.

A URL that does crash all drivers by design, is:

https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/sdk/tests/extra/lots-of-polys-example.html

recent-ish versions of NVIDIA driver still have/had a bug whereby you can get BSOD's but NVIDIA is working on it. Not sure what more we can do.
also, Firefox shouldn't crash when the driver gets reset (above DOS testcase). If it does, that's a bug I didn't know about.
Firefox shouldn't crash when running ANGLE and EXT_robustness handles it, at least in all cases I've seen. The results of a WGL crash are unpredictable, even with robustness enabled and working. I noticed on a few setups with WGL that I was never able to actually get a flag other than NO_ERROR from GetGraphicsResetStatus() (which means we can't detect a crash). My guess originally was that a lot of drivers report that they support robustness on Windows but really don't; perhaps a relic of their Linux drivers which actually do.

We need more information from OP before we can fix this, if there's still a problem.
You need to log in before you can comment on or make changes to this bug.