Validation fails with "Could not parse CSS file"

VERIFIED FIXED in 5.12.6

Status

addons.mozilla.org Graveyard
Developer Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: krupa, Assigned: basta)

Tracking

Details

(Whiteboard: [Step 2][validator], URL)

Attachments

(1 attachment)

1.94 MB, application/java-archive
Details
(Reporter)

Description

8 years ago
Created attachment 501415 [details]
test theme file

steps to reproduce:
1. Upload the attached test file

observed behavior:
Validation fails with "Could not parse CSS file"
Error: CSS file could not be parsed by the tokenizer.
foxdie_blue.jar/chrome/foxdie.jar/mac/browser/pageInfo.css

Should this be a failure?

Note: Validation doe snot fail in remora
(Assignee)

Comment 1

8 years ago
Validation would not fail in Remora; Remora does not parse CSS files, it only runs regex on them.

The problem is caused by an extended ASCII (or Unicode, I didn't look at it in a hex editor) character floating in the source. It *looks* like a curly brace, but it's actually a control character that's raising an unhandled exception in cssutils. I'm simply stripping out anything higher than the last "normal" ASCII character now:

https://github.com/mattbasta/amo-validator/commit/5132a047f650594641e3fd76c063a2199e1870fa
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

8 years ago
verified fixed by uploading the test file
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.