Add a dashboard for "Rate your Experience" submission

VERIFIED FIXED in 3.1

Status

P1
enhancement
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: aakashd, Assigned: davedash)

Tracking

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
Created attachment 501480 [details]
mock up of dashboard (only has 4 modifiers)

The "Rate Your Experience" survey submission offers a set of options to gauge on their experience on via a 5-point scale. For the dashboard, I'd like us to show time-base line graphs per each survey option.

y-axis: follows the 5 point likert scale
x-axis: time in days
Assignee: nobody → chowse
Created attachment 504618 [details]
RYE Dashboard Mockup

Notes:

* Graph at the top of the page shows the breakdown for all surveys submitted
  in the currently selected timeframe (in this case, the last 7 days).

* Each bar represents how often a particular choice (Poor, Fair, etc.) was
  made for that question. Choice are listed in ascending order, from Poor
  to Excellent.

* Hovering over a bar will provide a datatip w/ a count and % of total votes.

* In the 'Trends' box, each graph is a time series of the average rating for
  each day. To see the distribution of responses over time, use the 
  'Distribution' link in top-right corner of the box (mock-up forthcoming).

* The 'average' rating for a question is calculated like so:
  
     1. Map each rating to an integer, in ascending order of goodness.
        E.g. Poor = 1, Fair = 2, ..., Excellent = 5

     2. Take the average of these values for all responses on a given day.

     3. This is the average rating. In addition to this number, you can map
        it back to a name by rounding to the nearest whole number, then
        applying the mapping used in step 1 in reverse.
        E.g. 1.4 = Poor, 1.9 = Fair, 4.3 = Good, 4.6 = Excellent

* On the Y-axis, the numbers 1-5 represent votes from Poor to Excellent,
  respectively. If HighCharts permits, we could change these to the first
  character of each word, or use stars or other relevant symbols.

* Each chart will also have a datatip, providing the date, vote count, and
  average rating for each day.
Created attachment 504622 [details]
RYE Dashboard (Distributions)

The same mock-up, but with distribution trends listed.

* Each graph is now a stacked area chart. Each series is the number of votes
  cast for each possible answer. The answers are order from Poor to Excellent,
  bottom to top. The colors used are the same as those in the top chart.

* Like the average rating graphs, the distribution graphs have a datatip. If
  Highcharts support this, the tip should show the number/percentage of votes
  for every answer on that day.
(In reply to comment #2)
> Created attachment 504622 [details]
> RYE Dashboard (Distributions)
> 
> The same mock-up, but with distribution trends listed.
> 
> * Each graph is now a stacked area chart. Each series is the number of votes
>   cast for each possible answer. The answers are order from Poor to Excellent,
>   bottom to top. The colors used are the same as those in the top chart.
> 
> * Like the average rating graphs, the distribution graphs have a datatip. If
>   Highcharts support this, the tip should show the number/percentage of votes
>   for every answer on that day.

Can I get a labeled x-axis?  Otherwise this looks great.
Assigning this to Dave.
Assignee: chowse → dd
Depends on: 626840

Comment 5

8 years ago
we should also have a way to drill down on the search terms that were used to classify and count reports.

for example I can imagine "start-up time" or "page-load time" categories might be a combination of several search queries like "fast", "slow", "start", "first time", "loaded the browser",  "loading the page at"

a user of the dash board will probably want to drill into which terms are used, then maybe mix and match terms, or see samples of reports to dissect exactly where the problems lie. 

This is similar to what I described in bug 627558.

If the tool can also be generic enough that I could create and share my own dashboard that would be pretty cool too.
> for example I can imagine "start-up time" or "page-load time" categories might
> be a combination of several search queries like "fast", "slow", "start", "first
> time", "loaded the browser",  "loading the page at"
> 
> a user of the dash board will probably want to drill into which terms are used,
> then maybe mix and match terms, or see samples of reports to dissect exactly
> where the problems lie. 

These are not free-form text fields, they are specific questions e.g. startup time rated from 1-5.
http://github.com/fwenzel/reporter/commit/8c07e33
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 627558
As of today, this page: http://input.stage.mozilla.com/en-US/release/

1) no % total votes display on datatip
2) no distribution link/option displays
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #9)
> status: RESOLVED => REOPENED; cc: rbillings@mozilla.com; resolution: FIXED => As of today, this page: http://input.stage.mozilla.com/en-US/release/
> 
> 1) no % total votes display on datatip
> 2) no distribution link/option displays

We're not doing distribution.

Can you clarify #1?
From Comment 1: Hovering over a bar will provide a datatip w/ a count and % of total votes.
>> Hovering over shows a datatip with a date, and a count but no % of total votes
We're going to skip that also, it will clutter up the graph.

Marking as fixed, but those two issues are WONTFIXes.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Verified graph implementation and datatips displays - without distribution or the % of total votes on the datatip.
Status: RESOLVED → VERIFIED
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.