Closed Bug 623423 Opened 9 years ago Closed 9 years ago

Permaorange reftests on WinXP: editor/xul/empty-1.xul, editor/xul/autocomplete-1.xul, editor/xul/emptyautocomplete-1.xul, editor/xul/number-3.xul, editor/xul/number-5.xul, editor/xul/numberwithvalue-1.xul

Categories

(Core :: DOM: Editor, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b10

People

(Reporter: philor, Assigned: ehsan)

References

Details

Attachments

(3 files, 1 obsolete file)

Attached file reftest log
Now that we're running reftests on WinXP opt (as seen in http://tbpl.mozilla.org/?noignore=1), you can see that layout/reftests/editor/xul/input.css needs some adjustment for windows-default-theme when it's the XP default theme. The first one looks like it's just the way XP emptytext isn't italic, the rest appear to be padding differences.
Attached patch Patch (v1) (obsolete) — Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #502065 - Flags: review?(roc)
Attachment #502065 - Flags: approval2.0?
Attached patch Patch (v2)Splinter Review
Fixed the Windows XP user agent detection code.
Attachment #502065 - Attachment is obsolete: true
Attachment #502297 - Flags: review?(roc)
Attachment #502065 - Flags: review?(roc)
Attachment #502065 - Flags: approval2.0?
Comment on attachment 502297 [details] [diff] [review]
Patch (v2)

Make the class "winxp" I think just for clarity.
Attachment #502297 - Flags: review?(roc) → review+
Attached patch For check-inSplinter Review
Whiteboard: [orange] → [needs landing]
Whiteboard: [needs landing] → [xp-orange][needs landing]
http://hg.mozilla.org/mozilla-central/rev/5f34b7f0308d
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [xp-orange][needs landing] → [xp-orange]
Target Milestone: --- → mozilla2.0b10
Oddly, my patch in bug 658949 seems to "regress" this -- changing it from KNOWN FAIL to UNEXPECTED FAIL.  Somehow, that patch seems to break the "fails-if" lines added in comment 5 here...  Not sure why. (that patch is being backed out while I investigate)
Ah, figured it out, in bug 658949 comment 23.  Have a fix, & all is well -- sorry for spamming this bug.
Whiteboard: [xp-orange]
You need to log in before you can comment on or make changes to this bug.