Messed up graphics when Content was displayed in Plugins and Hardware acceleration is activated

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: mailc23, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: 4.0b8

Flash content (e.g. Video) will be displayed for some (Milli-)Seconds over the PDF file.
It happens also the other way round: An excerpt of the PDF file will be displayed in the Flash object.

After finally closing Firefox the latest Plugin content will be displayed again for some Milliseconds. (It would even do that if you open some other websites)

Reproducible: Always

Steps to Reproduce:
1. Start Firefox (Adobe Reader and Adobe Flash Player installed)
   - Use only one tab
2. Open Flash-Video (example: youtube: http://www.youtube.com/watch?v=lM3LcnDoma0 )
(optional): Open other websites
3. Open PDF-File (example: https://www.awxcnx.de/download/spurenarm_surfen_firefox.pdf ) ---- screenshot 1
4. Open other websites
5. Close Firefox 4 Beta ---- screenshot 2
Actual Results:  
see screenshots and Details

Expected Results:  
It shouldn't show those contents after visiting other sites.
(Reporter)

Comment 1

8 years ago
Created attachment 501634 [details]
screenshot 1
(Reporter)

Comment 2

8 years ago
Created attachment 501635 [details]
screenshot 2
(Reporter)

Comment 3

8 years ago
I couldn't find a similar bug so I created this one.
Does disabling Hardware Acceleration under Options/Advanced/General help?
(Reporter)

Comment 5

8 years ago
Yes, it helps.

And what does it mean?
Component: Plug-ins → Graphics
QA Contact: plugins → thebes
You might want to try out a recent Nightly (http://nightly.mozilla.org/) and test against it. Also please provide your Graphics Info from about:support (Bottom).
(Reporter)

Comment 7

8 years ago
This problem appeared firstly in beta 7 and appears still in the current beta 9
____________
Graphics
Adapter Description	ATI Mobility Radeon HD 2600
Vendor ID	1002
Device ID	9581
Adapter RAM	Unknown
Adapter Drivers	atiumdag atiumdva atitmmxx
Driver Version	8.403.0.0
Driver Date	8-11-2007
Direct2D Enabled	false
DirectWrite Enabled	false
WebGL Renderer	TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 6 2011 03:41:56)
GPU Accelerated Windows	1/1 Direct3D 9

Comment 8

8 years ago
I also have this issue as well, although not as much.
(Reporter)

Updated

8 years ago
Summary: Messed up graphics when Content is displayed in (Adobe?) Plugins → Messed up graphics when Content is displayed in (Adobe?) Plugins and Hardware acceleration is activated
(Reporter)

Updated

8 years ago
Summary: Messed up graphics when Content is displayed in (Adobe?) Plugins and Hardware acceleration is activated → Messed up graphics when Content was displayed in (Adobe?) Plugins and Hardware acceleration is activated
(Reporter)

Updated

8 years ago
Summary: Messed up graphics when Content was displayed in (Adobe?) Plugins and Hardware acceleration is activated → Messed up graphics when Content was displayed in Plugins and Hardware acceleration is activated
Can NOT reproduce on Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre
OS: Windows Vista → All
(Reporter)

Comment 10

8 years ago
Ok, now it seems to be fixed in the current beta 12.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.