Last Comment Bug 623610 - Remove support for geostd8
: Remove support for geostd8
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-06 08:11 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-04-23 12:05 PDT (History)
8 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (43.96 KB, patch)
2011-01-06 08:11 PST, :Ms2ger (⌚ UTC+1/+2)
smontagu: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-01-06 08:11:14 PST
Created attachment 501673 [details] [diff] [review]
Patch v1

Anne van Kesteren's research (<https://bitbucket.org/annevk/webencodings/>)
suggests that no other browser supports this charset. Also, it was never registered at IANA. I believe we should improve interoperability by dropping support.
Comment 1 Simon Montagu :smontagu 2011-01-06 08:57:16 PST
Removing support for things just because we're the only browser that supports them seems to me to be taking interoperability too far.
Comment 2 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2011-01-06 10:22:12 PST
What's the point in supporting them, though?  Is there content that uses this encoding?  If people are creating new content, wouldn't it be better if they use UTF-8 and indicate language with the lang attribute?
Comment 3 Anne (:annevk) 2011-01-07 07:04:31 PST
There is a couple of reasons I would like browsers to consider removing encodings only they support (Opera will in due course remove support for windows-sami-2 I hope):

1. Reduces code complexity.
2. Lowers the possibility that web content will rely on support.
3. Removes the possibility that web content will use it as label while assuming non-support because it is not tested in the browser that has support.

And overall I think that tightening up the legacy encodings so that they can become a fixed list of legacy encodings shared among all browsers in the long term is a good idea. It also gets us closer to the goal of being able to define exactly what you need to do to implement a browser that can process web content around the world.
Comment 4 Simon Montagu :smontagu 2011-01-10 01:33:36 PST
Gia, do you have any comments on this?
Comment 5 Anne (:annevk) 2011-12-27 16:49:33 PST
Ping.
Comment 6 Masatoshi Kimura [:emk] 2011-12-27 19:06:33 PST
Geostd8 is not even registered on the IANA registry.
https://www.iana.org/assignments/character-sets
Moreover, the implementation was broken until 2009.
https://bugzilla.mozilla.org/show_bug.cgi?id=472746
So I don't believe someone relies on the support for this encoding.
Comment 7 Simon Montagu :smontagu 2011-12-27 21:31:35 PST
Comment on attachment 501673 [details] [diff] [review]
Patch v1

Review of attachment 501673 [details] [diff] [review]:
-----------------------------------------------------------------

OK, so be it (though I would like to have got confirmation from someone in the Georgian community)
Comment 8 Gia Shervashidze 2011-12-28 10:36:28 PST
sorry [for the late answer],
Geostd8 is the encoding approved by the local government (not abolished yet).
For now there are [only] few sites using mentioned encoding for the content.

Anyway, personally i have no objection for removing the support.
Comment 9 :Ms2ger (⌚ UTC+1/+2) 2012-01-03 03:57:38 PST
Thanks.

https://hg.mozilla.org/mozilla-central/rev/b3030d5f893b
Comment 10 Eric Shepherd [:sheppy] 2012-04-23 12:05:31 PDT
Noted on:

https://developer.mozilla.org/en/Character_Sets_Supported_by_Gecko

Also listed on Firefox 12 for developers.

Note You need to log in before you can comment on or make changes to this bug.