image of previous page redrawn over current page

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
P3
normal
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: db48x, Assigned: Kevin McCluskey (gone))

Tracking

({regression})

Trunk
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001204
BuildID:    2000120404

mozilla covers the rendering of the current page with an image of the previously
visited page. It does it fairly well, though. Maybe a tad on the slow side.

Reproducible: Sometimes
Steps to Reproduce:
not entirely sure....
Open first page
browse to second page
hit back, immediatly alt tab out to another program
come back after new page has loaded

Actual Results:  Mozilla loads the first page, but then displays an image of the
previous page, over top of the current page (you can actually see it replace the
second page with an image of the first). Links, forms, image rollovers, etc all
still work on the second page, but not the ones from the first page.


Expected Results:  Expected it to just show the second page, obviously.

I can't reliably reproduce this problem, it's only happend twice. On the other
hand, the affected window would always draw that same image even after you'd
followed another link. Oh, and it only affected that one window, all my other
windows were fine.

The only other odd thing was that I had the font up to 120%, because the I'd had
to read some small type in the page just before I went back, and triggered the
bug. I'm not sure this makes much difference though.

I'm not sure why this bug is so hard for me to reproduce, I think there's a
timing issue. Kinda hard for me to duplicate things on a connection like mine,
every time is different.

Comment 1

17 years ago
over to layout.
Assignee: asa → clayton
Component: Browser-General → Layout
QA Contact: doronr → petersen

Comment 2

17 years ago
Changing to compositor
Assignee: clayton → kmcclusk
Component: Layout → Compositor
(Reporter)

Comment 3

17 years ago
Oooh, I did it again. I even got a couple of screen shots!

This time was different though. I'd been reading an HTML file locally, then a
little while later, I established an internet connection, and set off to see
what was on slashdot, by way of a bookmark on my personal toolbar, no back
button invloved.
(Reporter)

Comment 4

17 years ago
Created attachment 20911 [details]
first of two, note how scrolling reveals what's beneath the image.
(Reporter)

Comment 5

17 years ago
Created attachment 20913 [details]
and the second. This one shows the cool way selecting text redaws elements.

Comment 6

17 years ago
Win 98, build 2000121804: Although I can't reproduce this, I do consistently
see that when moving back and forward through the history, the initial page
loaded in that session always briefly flashes in the browser window before the
proper page is loaded. This may be related? Leaving as unconfirmed.

Comment 7

17 years ago
Marking NEW so someone can figure this out. I have no idea.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 8

17 years ago
I see this fairly often.

Cc'ing Dan, I vaguely recall him saying something like "and there's an 
embarrassing refreshing problem..."
Keywords: mozilla0.8, nsbeta1, regression

Comment 9

17 years ago
I just saw this on build 2001012720 win32 : I opened Moz for the first time
after a reboot, which opened www.mozilla.org. I then opened another URL
http://www.swiss-surnames.org/vol/sherlock.htm and when switching windows, the
image of mozilla.org appeared. After reloading the page it no longer did it.

Updated

17 years ago
Keywords: mozilla0.9
(Assignee)

Comment 10

17 years ago
Is this still a problem? I can not reproduce with todays build on WINNT.
(Assignee)

Comment 11

17 years ago
resolving bug as WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
Keywords: mozilla0.8
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.