All users were logged out of Bugzilla on October 13th, 2018

Playing with bookmarks in bookmarks menu messes them arround

RESOLVED DUPLICATE of bug 626341

Status

()

RESOLVED DUPLICATE of bug 626341
8 years ago
8 years ago

People

(Reporter: u336495, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre

I have about 10 bookmarks in bookmark menu with standard folders (recently bookmarked, history, recent tags). I use Firefox Sync to sync ma bookmarks beetween 2 computers. This sync messes up my bookmarks (but it's not a point).
So when I see some bookmarks in different order I want to drag them at correct position. Then I see that every time I try to move bookmark from position 3 to 8 for example, it moves on position 5. I then try again and it moves to position 1.
It never moves when I want but to a randomly selected position

Reproducible: Always

Steps to Reproduce:
1.try to move bookmarks in a bookmark menu
2.
3.
Actual Results:  
bookmarks move to a randomly selected position

Expected Results:  
bookmarks move there where I pointed

Comment 1

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre

Works for me. Please try by creating a new profile and check if you are able to reproduce. 
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile.
(Reporter)

Comment 2

8 years ago
I guess this must be related to Firefox Sync
I have FF nightly at home and latest beta at work. Both connected with sync.
I update bookmarks almost every day. Almost every page is a forum(www.skyscrapercity.com to be specific) so updating them is limited to changing last charachter in a URL (URL to latest page on a forum).
I started today FF beta at work. It synced bookmarks and messed them up. I try to move one to correct place but it moves to a diffrent. I then restart ff and this particular bookmark is on its right place.
To be specific it messes up only those bookamrks that are updated

Updated

8 years ago
Component: Bookmarks & History → Firefox Sync: Backend
Product: Firefox → Mozilla Services
QA Contact: bookmarks → sync-backend
Are we sure this is related to Sync? For example, does the problem go away on the affected computers when choosing "Stop Using This Account" from Sync Options? Do you have any other add-ons that hook into the bookmark system installed?

Sync does not do anything to bookmarks except during an actual sync. And even then its behaviour doesn't explain what you're seeing.
(Reporter)

Comment 4

8 years ago
Addons installed: 
Adblock plus
Clip to OneNote
Prospector
NoScript
TestPilot
Ubiquity
At work also: FireFTP

To be honest, present way of adding new computer to sync makes it almost impossible to do it again if i disconnect one (but it's a subject for another bug)
Will be disabling only bookmark sync enough to verify this?
(In reply to comment #4)
> Addons installed: 
> Adblock plus
> Clip to OneNote
> Prospector
> NoScript
> TestPilot
> Ubiquity
> At work also: FireFTP

None of these look like they interfere with bookmarks much.

> To be honest, present way of adding new computer to sync makes it almost
> impossible to do it again if i disconnect one (but it's a subject for another
> bug)

Not sure I understand. Does the easy setup not work for you?

> Will be disabling only bookmark sync enough to verify this?

Not really. When you completely disable Sync ("Stop Using This Account"), Sync unhooks itself completely and it's as if it wasn't there. at all.
(Reporter)

Comment 6

8 years ago
To connect another PC to a sync, FF generates code that I have to paste to a first PC to make it sync. After some time code changes. Then imagine I'm at work and want to add my work PC to sync with my home PC. I can't connect remotely to my home PC so I have to wait till I get home but before I get home this code changes few times so I'm unable to connect them. When there was only password and passphrase connecting 2 PCs was simpler. That's why I don't want to disconnect my work PC. 
But hey, I'm testing unstable versions. I should be aware that such situations may happen :). I'll disconnect tommorrow my work PC and see if that helps. For now, using my home PC with latest FF nightly, my bookmarks still moves to random positions when trying to arrange them. 
Even in Bookmarks library it's broken but only when playing with Bookmarks Menu.
Bookmarks toolbar and Unsorted bookmarks works fine.
(In reply to comment #6)
> To connect another PC to a sync, FF generates code that I have to paste to a
> first PC to make it sync. After some time code changes. Then imagine I'm at
> work and want to add my work PC to sync with my home PC. I can't connect
> remotely to my home PC so I have to wait till I get home but before I get home
> this code changes few times so I'm unable to connect them. When there was only
> password and passphrase connecting 2 PCs was simpler. That's why I don't want
> to disconnect my work PC. 

You can still type your username, password, and sync key into the other machine -- just click the "I'm not in front of my other computer" beneath the PIN entry boxes.

We emphasize the easy setup approach because it's easier -- email address, password, and sync key are a lot of characters to diligently type. And most users will have their other device with them: it'll be an Android device, or a netbook, etc.

The old approach is still available for those who can't or won't use easy setup.
(Reporter)

Comment 8

8 years ago
Ha, why I missed that option? ;)
(Reporter)

Comment 9

8 years ago
FF4b8:
Firefox Sync disabled - still broken
then Start Firefox with addon disabled - still broken
then Completly new profile with almost the same bookmarks - ....works fine
So what can be wrong with my profile? And why it is broken on both machines?
That's a good question! But it seems unrelated to Sync. Moving this bug back to Firefox :: History & Bookmarks.
Component: Firefox Sync: Backend → Bookmarks & History
Product: Mozilla Services → Firefox
QA Contact: sync-backend → bookmarks
Duplicate of this bug: 627830

Comment 12

8 years ago
I have also experienced this behaviour during some "stress testing" of
Firefox 3.6.15 + Sync 1.6.1 with a private sync server.  Here is the test method (as far as I can accurately recall - I wasn't making notes until this behaviour started):

1. Created two new profiles (Profile1 and Profile2)
2. Disabled all extensions and plugins (except 3 RealPlayer plugins, which seems to always become re-enabled) in each.
3. Deleted all bookmarks in each profile.
4. Imported around 6000 bookmarks (some having duplicate names, duplicate URLs, etc) into Profile1.
5. Created new server account, using Profile1
6. Synced Profile1 to the server.
7. Set up Profile2 to use the same server account.
8. Synced Profile2 to the server.
9. On Profile 2, moved (using drag and drop on the drop-down menu) some bookmarks and bookmark folders, and (using Organize Bookmarks) renamed some, deleted some and duplicated some.
10. Synced Profile2 to the server.
11. Synced Profile1 to the server.
12. Changed bookmarks on Profile1, as per Step 9.
13. Synced Profile1 to the server.
14. Repeated steps 8-13 again.

After this process, Profile1 was in a similar state to that described by the original reporter, RooD.  Dragging bookmarks around in the drop-down menu would result in the item that was dragged being placed in a different position to where it was dropped, except when it was dropped at the top of the list, where it always seemed to succeed.  As far as I could tell from a few minutes observation, items dropped in position N would be moved to position 2*N +/- 1 (separators and sub-menus counting as 1 item).  This behaviour persisted until I rebooted Profile1.  Profile2 behaved normally throughout.

Unfortunately, I don't have any sync log files for this - I had the logging settings on TRACE and the logs cycled too rapidly (sync needs to have a method of preserving more than 2 log files, but that's another story).

I've tried to reproduce this behaviour on two more clean profiles after updating them to Sync 1.6.3, but haven't seen it again yet (although I have seen a different but possibly related problem: dragging and dropping during an active sync causes sync to be lost - to be reported separately).

I've never seen any similar behaviour on Firefox until installing Sync.
Imho, this is just bug 626341 caused by bug 634401.

Whoever can reproduce, please try reproducing in Firefox 4.0 and report back.
(Reporter)

Comment 14

8 years ago
since i created new profile (2 months ago) I can't reproduce this problem using 
beta and nightly versions of FF4
Thanks, RooD. Closing this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 626341
You need to log in before you can comment on or make changes to this bug.