ff try to download large favicons (350mb!) which cause bad network speed

RESOLVED WONTFIX

Status

()

Firefox
General
--
minor
RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: ch_de, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Build Identifier: 4.0b7

Try to visit a website with a damaged favicon with a size of 350mb. ff try to download the favicon and that cause network lags because bandwidth is busy. 

maybe there should be a size limit for favicons. 

Reproducible: Always

Steps to Reproduce:
1. visit a site with a very large favicon
2. bandwidth is used 100% (while downloading favicon)
3. all other network processes are laggy
The website could also integrate a 500mb background image or other resource and you would get the same thing.....

Updated

7 years ago
Version: unspecified → Trunk
Exactly. There are an endless number of ways for websites to do dumb things.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 813864
You need to log in before you can comment on or make changes to this bug.