OK button in Link Properties is not enabled after selecting named anchor from list

VERIFIED FIXED in mozilla0.9

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: bijals (gone), Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Steps:
1) Open a blank document
2) Type "abcd"
3) Hit return
4) Type "abcd" and place caret in front of the "a"
5) Click on "Anchor" button and create a new anchor called "a"
6) Select the first "abcd" and click the "Link" button
7) Click "more" to add anchor to link

Actual Results: Notice that "OK" button on "Link" dialog is disabled so when I 
click okay nothing happens

Expected Results: "OK" button enabled and I have a link to an anchor for the 
first "abcd" text

Build Date/Platform: 2000120804 using NT

Comment 1

17 years ago
OK button remains grey, you must click in the Link Location field and enter a
space or characer to enable the link button -- selecting the named anchor should
have enabled the button
Assignee: beppe → cmanske
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 2

17 years ago
Beth is correct, the problem is enabling the OK button -- I just found this
problem as well! I changed the summary to be more specific.
Actually, even though the button looks disabled, clicking on it does work
(obviously that's a different bug)!
Status: NEW → ASSIGNED
Summary: Can not create an anchor link → OK button in Link Properties is not enabled after selecting named anchor from list
(Reporter)

Comment 3

17 years ago
Hmm...  I clicked on the disabled and I was not able to get anchor to work as 
shown in the steps below.
(Assignee)

Comment 4

17 years ago
Created attachment 21837 [details] [diff] [review]
fixes bug
(Assignee)

Comment 5

17 years ago
The "ChangeText()" method is called when user types in the URL textfield, so
simply call this when an anchor or heading is clicked on to do OK button enabling.

(Assignee)

Comment 6

17 years ago
Ok is now enabled when you click on an item in Named Anchors and Headings lists.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
verified in 1/16 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.