Closed Bug 623957 Opened 9 years ago Closed 9 years ago

www.linkedin.com crash firefox [@ js::GetFlatUpvar(JSContext*, JSObject*, int, js::Value*) ]

Categories

(Core :: JavaScript Engine, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 616762

People

(Reporter: whan.kharlos, Unassigned)

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

Just entering at www.linkedin.com crash firefox

Reproducible: Always

Steps to Reproduce:
1.type www.linkedin.com
2.firefox crash
3.
Actual Results:  
Firefox is crashing

Expected Results:  
Firefox should render the page requested

I'm using firefox 4.0beta portable
Please post a crash ID from about:crashes
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

>I'm using firefox 4.0beta portable
In that case it might be possible that the crash report doesn't work.
You have to get debug symbols and use a debugger to generate a stack trace in that case. Firefox portable is not from Mozilla.org
Or download an official mozilla.org installer for testing.
Version: unspecified → Trunk
Crash reporter is working, I think!
Every time it crashed, it showed a pop-up window asking me for sending a report.
Can you give the id matti requested?
>Can you give the id matti requested?

I don't know what "id matti" is?
Did you read the link in comment 1 that matti gave you?
Ok sorry.
about:crashes give this: bp-66b4e3dd-6b60-434a-9fd0-946b02110107
And it takes me to http://crash-stats.mozilla.com/report/index/bp-66b4e3dd-6b60-434a-9fd0-946b02110107

And a litle bit more: when I try to access this page, it crashes too. May be something about cgi?

I hope it be useful.
0 	mozjs.dll 	js::GetFlatUpvar 	js/src/jsfun.cpp:1264
1 	mozjs.dll 	js::Shape::get 	js/src/jsscopeinlines.h:256
2 	mozjs.dll 	js_NativeGet 	js/src/jsobj.cpp:5073
3 	mozjs.dll 	ScopeNameCompiler::retrieve 	js/src/methodjit/PolyIC.cpp:1495
4 	mozjs.dll 	js::mjit::ic::Name 	js/src/methodjit/PolyIC.cpp:1913
5 		@0x2ad2f7 	
6 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:745
7 	mozjs.dll 	CheckStackAndEnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:770
8 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:787
9 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:654
10 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:737
11 	mozjs.dll 	js_fun_call 	js/src/jsfun.cpp:2225

Firebug is installed and the stack looks similar like bug 616762 and bug 618549
Assignee: nobody → general
Component: General → JavaScript Engine
Keywords: crash
Product: Firefox → Core
QA Contact: general → general
Summary: www.linkedin.com crash firefox → www.linkedin.com crash firefox [@ js::GetFlatUpvar(JSContext*, JSObject*, int, js::Value*) ]
Yes it seems that I was forcing Firebug 1.6 to work with Firefox 4.0b8 which are not compatible.
I updated firebug to a newer version and it doesn't crash anymore.

Greetings!
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616762
Crash Signature: [@ js::GetFlatUpvar(JSContext*, JSObject*, int, js::Value*) ]
You need to log in before you can comment on or make changes to this bug.