Line break on the "free download" button

VERIFIED FIXED in 1.1

Status

www.mozilla.org
General
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: zpao, Assigned: sgarrity)

Tracking

unspecified
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

Created attachment 502058 [details]
screenshot (showing bug)

See screenshot.

Looks to be a font issue. dholbert says it looks fine for him, but he has the ubuntu-restricted-extras package installed, which includes Microsoft fonts (including apparently Georgia).

So we should add a better fallback font and/or but   to at the very least keep "free download" from splitting.
Created attachment 502060 [details]
screenshot (no bug)

Here's a screenshot of what I see.  The font for at least "3.6" is noticeably different from zpao's screenshot (my "3" dips below the baseline whereas zpao's does not), so it's almost certainly a font difference between my computer & zpao's. (likely from ubuntu-restricted-extras, as zpao noted)
Attachment #502058 - Attachment description: screenshot → screenshot (showing bug)
I did some more looking into this and the issue is that for that it the use of font family Georgia with a fallback of serif and a font size of 22px.  It is the combination of using 22px and a generic serif in combination as a fallback that is causing the issue.  It would be better to use a font size that is more universally supported in serif fonts (like 24px).

For what it is worth, I fixed this problem for me under Firefox 4.0b8pre with the release STIX 1.0 fonts installed by modifying my Firefox default serif font to be "STIX General".
To clarify what I was trying to say above a bit.  If you actually have Georgia (which is the preferred) font installed it supports a 22px size so everything fits.  The problem is that if you do not and it falls back to the system default serif font, that is likely to only support "normal" font sizes of which 22px is not one so it will probably end up using 24px instead, which results in making the "Firefox 3.6" part wide enough so that the "free download" part does not fit without wrapping.

I, therefore, would suggest redoing the layout to specify and display properly with a font size of 24px.

An even better solution would be to specify that the entire string not wrap and auto size the width of the green bar depending on the text width.
(In reply to comment #2)
> For what it is worth, I fixed this problem for me under Firefox 4.0b8pre with
> the release STIX 1.0 fonts installed by modifying my Firefox default serif font
> to be "STIX General".

I was able to achieve the same results by specifying the more universally available under Linux "Century Schoolbook L" font as the default Firefox serif font.

Comment 5

8 years ago
Steven, can you help here?
Assignee: nobody → steven
Target Milestone: --- → 1.1
Duplicate of this bug: 624020
(Assignee)

Comment 7

8 years ago
(In reply to comment #5)
> Steven, can you help here?

Yup - It looks like this is happening when the Georgia font isn't available (often the case on linux). Will fix.
Status: NEW → ASSIGNED
(Assignee)

Comment 8

8 years ago
Fixed in trunk in r80556. Merged to stage in r80581. QA should be sure to include IE6 in testing, as that browser is specifically targeted with some side-effects on this fix.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Keywords: qawanted
problem still exists on http://www-trunk.stage.mozilla.com/en-US/about/ using Firefox 3.6 on Ubuntu.
Status: RESOLVED → REOPENED
Keywords: qawanted
Resolution: FIXED → ---
(Assignee)

Comment 10

8 years ago
Re-fixed in trunk in r80594. Re-merged to stage in r80595.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Keywords: qawanted
Resolution: --- → FIXED
FWIW, I filed  Bug 626730 for a similar issue on /firefox/ instead of /about/.
pushed to production
r81589 | jlong@mozilla.com | 2011-01-25 14:48:17 -0500 (Tue, 25 Jan 2011) | 8 lines
verified fixed http://www.mozilla.com/en-US/about/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.