"Sign in with Mozilla" design

RESOLVED DUPLICATE of bug 648386

Status

RESOLVED DUPLICATE of bug 648386
8 years ago
8 years ago

People

(Reporter: hello, Assigned: smartell)

Tracking

Details

(Reporter)

Description

8 years ago
For the upcoming Mozilla ID service we need a button which we will have sites place on their pages.

We aren't sure what kind of design might work best, so at this stage we'd like to see a few mockups. Some of the choices we've been thinking of:

[l]Sign in
[l]Sign in with Mozilla
[l]Mozilla Sign-in

where [l] is a logo--perhaps the Mozilla logo, or perhaps something else like a key.

It might also be useful to mock up a pop-up that might come up when clicking the button.  Click the one in the Facebook page below for an example. On this page we could have a bit more text, and could say something like "Sign in with your Mozilla Account" for example. This page could also play on the logo from the button.

Examples:

http://dev.twitter.com/pages/sign_in_with_twitter (bottom)
http://developers.facebook.com/docs/reference/plugins/login
(Reporter)

Comment 1

8 years ago
A note about timing:

We would like to have a public release of the service around mid-Q1, and so we need to have the branding ready (or close to) before then.

In the meantime we can use placeholders, so this doesn't block development.

Comment 2

8 years ago
Sean, this is the end result of the ID naming discussion we had today. I can fill you in on the details...let's talk soon.
Assignee: jslater → smartell
(Reporter)

Comment 3

8 years ago
Howdy! Any updates here?

Comment 4

8 years ago
Sorry, this got buried under some Fx4 work...will pick things up with Sean again. Thanks for the reminder-
(Reporter)

Comment 5

8 years ago
Here's the project page:

https://intranet.mozilla.org/Projects/MozillaID

Though maybe that's too much info, I'm not sure.

Also, I've pinged chowse about working on UX flows and mockups, but for initial branding/design work on the button itself I don't think you should need those.

Comment 6

8 years ago
That plus the info in comment #0 is very helpful, thanks Dan. Will follow up with Sean and we'll be in touch soon.

One more thing - do you have a specific deadline for this? That would really help me prioritize this vs all the other work we have going on now.

Comment 7

8 years ago
Dan, any word on that deadline?
(Reporter)

Comment 8

8 years ago
Hey, our first milestone is in 2 weeks. I'd like to have some button options before then. I expect we'll need a couple of iterations, so how about a first cut a week from now? Does that sound reasonable?
(Assignee)

Comment 9

8 years ago
Curious, is this the same as bug 648386?
(Reporter)

Comment 10

8 years ago
Yes, pretty much.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648386
You need to log in before you can comment on or make changes to this bug.