session is lost if it includes only one page

RESOLVED DUPLICATE of bug 610339

Status

()

RESOLVED DUPLICATE of bug 610339
8 years ago
6 years ago

People

(Reporter: otaznik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

If I have only app tabs and one other tab, session is not saved.  I am using warnOnQuit which is skipped because of this in nsBrowserGlue.js:

if (pagecount < 2)
  return;


Reproducible: Always

Steps to Reproduce:
1. enable warnOnQuit (you have to also set default tabs to blank or homepage to really enable this)
2. open one tab (you can open as many app tabs as you wish)
3. quit
Actual Results:  
Session lost without warning.

Expected Results:  
Dialog on quit.
(Reporter)

Comment 1

8 years ago
I forgot to mention:  app tabs will be restored.
Yes. The 1 tab case is still specialized. This is no different than what we've been doing for a few versions now.

We'll continue this for now, but perhaps that will change in the future.

This could probably be duped to something else, so going to leave open for triage later.
(Reporter)

Comment 3

8 years ago
I know about it but then I am sorely missing the quit dialog feature.  So this bug can be rephrased as "Firefox ignores warnonquit setting when only 1 (non-app) tab is open" (I think this is also true for warnonrestart).
Can't seem to find a potential dupe for this one, Paul?
Whiteboard: [dupeme?]

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610339
(Reporter)

Comment 6

6 years ago
Created attachment 636180 [details] [diff] [review]
proposed fix
Hey Adam, thank you for your patch but unfortunately this bug has been marked as a duplicate of bug 610339. All the work should happen in that bug. It already has a patch but the work has stalled. If you'd like to contribute to that bug please have a look at its patch and if you might want to merge the two and/or address Paul's feedback. Thank you!
(Reporter)

Comment 8

6 years ago
It's different problem.  I don't care about multiple windows, I care about session exit dialog.  I patch my iceweasel with my patchset -- do as you wish, I'm just backing up my patch and sharing it with others.
You need to log in before you can comment on or make changes to this bug.