Exit bookmark manager, Mozilla closes down & crashes (JS3250.DLL)

VERIFIED DUPLICATE of bug 62401

Status

SeaMonkey
Bookmarks & History
P3
major
VERIFIED DUPLICATE of bug 62401
17 years ago
13 years ago

People

(Reporter: Pete, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

Trunk
x86
Windows 95
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
- open Mozilla
- choose bookmarks / manage bookmarks
- choose file / quit
all Mozilla windows close gracefully then the message:
  "Mozilla caused an invalid page fault in
   module JS3250.DLL at 0157:60b2ce8b"

if quit bookmarks by Alt-F4 or the crosshair it closes ok,
but if you then File / Exit on the Navigator window the crash happens

this bug is repeatable, apart from one time I tested with 3 
navigator windows open & the javascript console, it didnt 
crash but alas this 'solution' was non repeatable

software:
Windows 95 OSR2.5 + all significant patches
JavaScript module JS3250.dll version 4.0
Mozilla/5.0 (Windows; U; Win95; en-US; m18) Gecko/20001208

62392 'IPF on startup in JS3250.DLL' is similar but doesnt 
appear to be the same

Registers:
EAX=0072fldc CS=0157 EIP=60b2ce8b EFLGS=00010202
EBX=60050000 SS=015f ESP=018ffbe0 EBP=018ffbf4
ECX=00000000 DS=015f ESI=00882980 FS=36c7
EDX=00000001 ES=015f EDI=0072fldc GS=0000
Bytes at CS:EIP:
ff b0 f8 21 00 00 ff 15 e0 80 b4 60 59 c3 8b 44
Stack dump:
60b17713 0072fldc 00880660 00000000 60050000
018ffc6c 60b11ca7 00882980 00000002 60a713c5
00882980 00000000 60a71387 00880660 60a728fb
60a723a6

understanding the values in registers is too deep for my knowledge,
but if its any help, some values above repeat on subsequent tests 
of this bug:
EAX=common value     CS=exclusive value  EIP=value changes  EFLGS=common value
EBX=exclusive value  SS=exclusive value  ESP=value changes  EBP=value changes
ECX=common value     DS=exclusive value  ESI=value changes  FS=value changes
EDX=common value     ES=exclusive value  EDI=common value   GS=common value

pete
(Reporter)

Updated

17 years ago
Summary: Exit bookmarks, Mozilla crashes & closes down (JS3250.DLL) → Exit bookmark manager, Mozilla closes down & crashes (JS3250.DLL)

Comment 1

17 years ago
Confirming, adding crash keyword, I see this too on build 2000120820 win32.
It takes about 3 seconds after all windows have disappeared before crashing.
Is this related to bug 24607?
Fabian.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 62401 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.