Firefox.exe task executes w/ low-ram usage (2mb) and no window appears

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: purple2k, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120413])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

I don't remember when this issue started, but it was definitely present in the last 4-5 betas of firefox 4.

When firefox is NOT running (no firefox.exe or plugin-container.exe tasks exist) - I click on the firefox icon, firefox.exe executes and you can see it on the task manager, it hogs ~2mb of ram and no window appears.

One of two things can happen next -

A) I click on the icon again and another 2mb instance of firefox.exe appears in task manager but again, no window.
B) the window appears and works as usual.

After the first launch attempt, 49% of the time I repeatedly get to A with each additional click (creating multiple 2mb tasks with no window) until I end-task them and try again to eventually get to B, and 49% of the time the 2nd launch will get me to B. Finally, 2% of the time, it will work on the first run.

I can confirm the following:

1) no malware, spyware or adware exist on the box (Microsoft Security Essentials is monitoring) and I also did a spy-bot scan.
2) Uninstalling (and manually deleting firefox and profile directories) then reinstalling did not solve the problem.
3) the 2mb firefox.exe process is indeed the correct executable and not a trojan-replaced or infected one.
4) I also tried closing as many processes (end-task) to see if something was interfering, keeping only the system crucial processes. still, no go.

I will be happy to provide as much additional information as possible.

Reproducible: Sometimes

Steps to Reproduce:
1. Run firefox (in safe-mode, regularly, -P, from command line, from shortcut - ANY WAY YOU WANT).

Actual Results:  
Firefox window won't appear, but task exist.

Expected Results:  
Have firefox run regularly.
Creating a stacktrace for the hang with this instructions could help
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

Attach the stacktrace using the "add an attachment" link.

Updated

7 years ago
Summary: Firefox.exe task executes w/ low-ram usage (2mb) and no window appears (not your typical bug report - a lot of info included) → Firefox.exe task executes w/ low-ram usage (2mb) and no window appears
Version: unspecified → Trunk
(Reporter)

Comment 2

7 years ago
Created attachment 502445 [details]
debug as requested. after debug-->go, firefox would load then no window appears.
Attachment #502445 - Attachment mime type: application/octet-stream → text/plain
I'm sorry but the stacktrace doesn't tell me much, all Threads seem to be in windows system code.

Comment 4

7 years ago
exactly same problem here...

I did a full, clean re-install, rollback to 3.x, reinstalled graphic drivers and DirectX, none of this helped...

Firefox starts (firefox.exe process in task manager), but no visible windows...
cant reproduce on Firefox 11, 12b5,13 and 14

for support please ask question in https://support.mozilla.org/questions/new
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [testday-20120413]
You need to log in before you can comment on or make changes to this bug.