New Firefox Theme becomes broken after switching between Aero and Classic themes

RESOLVED DUPLICATE of bug 621857

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 621857
8 years ago
8 years ago

People

(Reporter: Ryuji, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110108 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20110108 Firefox/4.0b9pre

New Firefox theme will become broken if you repeatedly(sometime once) change the window background theme.

The Theme will appear black in colour, the Minimize, Maximize,Close buttons are gone. 

Reproducible: Always

Steps to Reproduce:
1. Open Firefox 
2. Open a few tabs in a few groups(how many groups or tabs will not affect the bug)
3. Minimize Firefox
4. Right click your background, select personalize.
5. change your 'current theme' and change it to Window Classic
6. Change your theme back to your 'current theme'

7. Maximize Firefox, you will find that the minimize, Restore down and Close buttons are gone and if you restore down the window the titlebar and tab bar will be black in colour. (if you cannot get the bug, repeat step 5 and 6)

Actual Results:  
Minimize, Restore down and close button is gone and the titlebar and tab bar appear black in colour.

Expected Results:  
Theme appear as what it supposed to look like.
(Reporter)

Comment 1

8 years ago
Created attachment 502330 [details]
Missing button after step 5 and 6 (once/repeatedly)
(Reporter)

Comment 2

8 years ago
Created attachment 502331 [details]
Black titlebar and tab bar if you restore down or move the Window
(Reporter)

Comment 3

8 years ago
Created attachment 502332 [details]
Wrong position of Panorama button in new window

If after Step 7, you open a new window, you will get a normal new window. However, when you maximize the new window, you will realize that the panorama button is wrongly positioned.
(Reporter)

Updated

8 years ago
Component: General → Theme
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Depends on: 569850
(Reporter)

Comment 4

8 years ago
Note: in step 5 your 'current theme' must be a Aero theme.

This bug cannot be produced if you change your theme to Aero basic and back to Aero theme again. (because I tried it out, but no bug is produced.)
Summary: Firefox theme becomes broken after switching Windows background themes → New Firefox Theme becomes broken after switching between Aero and Classic themes
QA Contact: general → theme
(Reporter)

Comment 5

8 years ago
This should block beta 9/beta 10 release.
This is a duplicate of Bug 621857

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
No longer depends on: 569850
Resolution: --- → DUPLICATE
Duplicate of bug: 621857
You need to log in before you can comment on or make changes to this bug.