the firefox beta download link is BROKEN

VERIFIED WORKSFORME

Status

()

--
major
VERIFIED WORKSFORME
8 years ago
8 years ago

People

(Reporter: mdlautner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.19) Gecko/2010061201 Firefox/3.0.19 Flock/2.6.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.19) Gecko/2010061201 Firefox/3.0.19 Flock/2.6.0

when you click the link to download the latest beta version it takes you to a HELP PAGE!!! NOT THE FRIGGIN DOWNLOAD PAGE!!! THIS IS REALLY STARTING TO **** ME OFF AS I HAVE BEEN TRYING TO INSTALL THE DAMN PROGRAM FOR THE PAST 4 HOURS AND IT DOES NOT **** WORK!!!

Reproducible: Always

Steps to Reproduce:
1. install beta from home page
2. click give feedback
3. follow link to page with download button for latest beta
4. click download
5. repeat for 5 hours and freak out because it does not work
Actual Results:  
it still takes me to a help page instead of the download page

Expected Results:  
TAKE TO TO THE **** PAGE TO INSTALL THE LATEST GOD DAMNED BETA VERSION OF **** FIREFOX!!!

YOU **** SUCK MOZILLA!!! YOU **** SUCK!
1) open http://www.mozilla.com/en-US/firefox/all-beta.html
2) click on very big, orange "Firefox beta , Free Download" button
3) you get a redirect to a new page and my browser opens the download window
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.