Closed Bug 624311 Opened 9 years ago Closed 3 years ago

Please stop sending "Empty string passed to getElementById()."

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 964631

People

(Reporter: johnjbarton, Unassigned)

References

Details

In FF4.0b9pre tracemonkey I get several messages:
Warning: Empty string passed to getElementById().

These may be important for platform devs but we can't stop them in the JS world.

https://bugzilla.mozilla.org/show_bug.cgi?id=572614#c7
OS: Windows 7 → All
Hardware: x86 → All
Blocks: 630101
Dear reporter, 

Can you please provide us some steps to reproduce? 
Focus on explaining: 

*Get the exact build ID or build configuration from "about:" 
*In what way are you getting this error? 
*What environment have you set up? (have/not have a FF clean profile, addons, etc)

This will be easy for us to have a clear reproducing algorithm for this issue. 

Thanks!
Open
http://www.mozilla.org/projects/firefox/prerelease.html
Then look at Firefox > Tools > Error Console
Error: document.getElementById(ids[i]) is null
Source File: http://www.mozilla.org/projects/firefox/prerelease.html
Line: 47
oh, sorry wrong message
Depends on: 1216668
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 964631
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.