Linux Qt tryserver builds dying with "/usr/bin/ld: cannot find -lQtGui"

RESOLVED DUPLICATE of bug 624428

Status

RESOLVED DUPLICATE of bug 624428
8 years ago
5 years ago

People

(Reporter: philor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1294626304.1294628614.3270.gz (and every one I've looked at since I got my first email telling me that I burned it, and turned on scraping so I could see what was wrong the next time)
Linux QT tryserver build on 2011/01/09 18:25:04 
try-linux64-slave02
(huh, and why is a linux64 build named "Linux" rather than "Linux x86-64"?)

/usr/bin/ccache /tools/gcc-4.3.3/installed/bin/g++  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -gdwarf-2 -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -gdwarf-2 -Os -freorder-blocks -fomit-frame-pointer  -fPIC -shared -Wl,-z,defs -Wl,-h,libmozalloc.so -o libmozalloc.so  mozalloc.o mozalloc_abort.o mozalloc_oom.o     -lpthread    -Wl,-rpath-link,/builds/slave/try-linuxqt/build/obj-firefox/dist/bin -Wl,-rpath-link,/usr/local/lib   -ldl  -L/tools/qt-4.6.3/qt/lib/ -lQtGui -lQtNetwork -lQtCore -lQtDBus -lQtXml -lQtOpenGL   
/usr/bin/ld: cannot find -lQtGui
collect2: ld returned 1 exit status
(Reporter)

Comment 1

8 years ago
Oh, maybe the fact that it's building on linux64 slaves is the whole of the problem, since the successful ones on m-c and TM are on non-64 slaves.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624428
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.