If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash [@ js::AbortRecordingIfUnexpectedGlobalWrite ]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash})

Trunk
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

7 years ago
Crash Report from crash-stats - [@ js::AbortRecordingIfUnexpectedGlobalWrite ]

http://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&date=2011-01-09%2018%3A00%3A00&signature=js%3A%3AAbortRecordingIfUnexpectedGlobalWrite&version=Firefox%3A4.0b9pre

Likely startup crash due to bad addon or so -> investigating

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	js::AbortRecordingIfUnexpectedGlobalWrite 	js/src/jstracer.h:1870
1 	mozjs.dll 	js_DefineNativeProperty 	js/src/jsobj.cpp:4694
2 	mozjs.dll 	js_DefineProperty 	js/src/jsobj.cpp:4549
3 	mozjs.dll 	exn_resolve 	js/src/jsexn.cpp:511
4 	mozjs.dll 	CallResolveOp 	js/src/jsobj.cpp:4792
5 	mozjs.dll 	js_GetProperty 	js/src/jsobj.cpp:5355
6 	mozjs.dll 	JS_GetProperty 	js/src/jsapi.cpp:3745
7 	mozjs.dll 	exn_toString 	js/src/jsexn.cpp:803
8 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:700
9 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
10 	mozjs.dll 	js_TryMethod 	js/src/jsobj.cpp:6261
11 	mozjs.dll 	js::DefaultValue 	js/src/jsobj.cpp:5909
12 	mozjs.dll 	js_ValueToString 	js/src/jsstr.cpp:3663
13 		@0x17d073 	
14 	xul.dll 	XPCWrappedNative::GetWrappedNativeOfJSObject 	js/src/xpconnect/src/xpcwrappednative.cpp:1765
15 	mozjs.dll 	JS_ValueToString 	js/src/jsapi.cpp:492
16 	xul.dll 	XPCConvert::JSValToXPCException 	
17 	xul.dll 	XPCConvert::JSValToXPCException 	
18 	nspr4.dll 	md_UnlockAndPostNotifies 	nsprpub/pr/src/md/windows/w95cv.c:169
19 	xul.dll 	nsXPCWrappedJSClass::CheckForException 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1081
20 	xul.dll 	XPCConvert::NativeData2JS 	js/src/xpconnect/src/xpcconvert.cpp:494
21 	xul.dll 	nsTimerImpl::Release 	xpcom/threads/nsTimerImpl.cpp:90
22 	nspr4.dll 	PR_Unlock 	nsprpub/pr/src/threads/combined/prulock.c:347
23 	mozjs.dll 	StopRequest 	js/src/jsapi.cpp:877
24 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1939
25 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:657
26 	mozjs.dll 	JSContext::popSegmentAndFrame 	js/src/jscntxt.cpp:2069
27 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:858
28 	mozcrt19.dll 	arena_malloc_small 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:3783
29 	xul.dll 	xptiInterfaceInfo::GetName 	xpcom/reflect/xptinfo/src/xptiprivate.h:358
30 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1738
31 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:588
32 	user32.dll 	DispatchMessageW 	
33 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
34 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:428
(Reporter)

Comment 1

7 years ago
List of Extensions (from crash-stats)

Extension 	Extension Id 	Version 	Current?
Xmarks Sync 	foxmarks@kei.com 	3.8.7 	3.9.2
FastestFox - Browse Faster 	smarterwiki@wikiatic.com 	4.1.7 	4.1.8
	https-everywhere@eff.org 	0.9.2 	
	{F8CC37C3-CBEB-4A00-8CBF-26A88693F0C5} 	2.2010.10.11 	
LastPass Password Manager 	support@lastpass.com 	1.70.0 	current
	christmas@browsernation.com 	1.2.3 	
Personas Plus 	personas@christopher.beard 	1.6.1 	current
FlashGot 	{19503e42-ca3c-4c27-b1e2-9cdb2170ee34} 	1.2.7 	current
Adblock Plus 	{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} 	1.3.3 	current
IDM CC 	mozilla_cc@internetdownloadmanager.com 	7.2.2 	6.9.1
	{972ce4c6-7e08-4474-a285-3208198ce6fd} 	4.0b9pre
(Reporter)

Comment 2

7 years ago
so i was unable to reproduce the crash with the extensions above - but still trying

Comment 3

7 years ago
There was a fix to a bug in AbortRecordignIfUnexpectedGlobalWrite in d08f63692c60 which was merged to m-c on the 8th with df3c1150dd7a.  The buildid also says the 8th.  The merge happened in the early hours of the 8th, so does this mean that the fix is included with this build?
Luke: was that for bug 597940 or an unfiled followup?

/be

Comment 5

7 years ago
(In reply to comment #4)
> Luke: was that for bug 597940 or an unfiled followup?

bug 597940 comment 22
Crash Signature: [@ js::AbortRecordingIfUnexpectedGlobalWrite ]

Comment 6

5 years ago
The tracer was removed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.