Error: Task upload.tasks.generate_image_thumbnail ... IOError(2, 'No such file or directory')

VERIFIED FIXED in 2.6

Status

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: paulc, Assigned: paulc)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gallery][qa-])

(Assignee)

Description

8 years ago
This probably happens as we attempt to generate a thumbnail for an object that was *just* deleted. Investigate if this can be prevented easily.


Task upload.tasks.generate_image_thumbnail with id d622ea9b-32e4-448a-b5af-6d571676d0d4 raised exception:
"IOError(2, 'No such file or directory')"


Task was called with args: (<ImageAttachment: uploads/images/snap.png>, u'snap.png') kwargs: {}.

The contents of the full traceback was:

Traceback (most recent call last):
  File "/data/www/support.mozilla.com/kitsune/vendor/packages/celery/celery/execute/trace.py", line 34, in trace
    return cls(states.SUCCESS, retval=fun(*args, **kwargs))
  File "/data/www/support.mozilla.com/kitsune/vendor/packages/celery/celery/task/base.py", line 248, in __call__
    return self.run(*args, **kwargs)
  File "/data/www/support.mozilla.com/kitsune/vendor/packages/celery/celery/decorators.py", line 52, in run
    return fun(*args, **kwargs)
  File "/data/www/support.mozilla.com/kitsune/apps/upload/tasks.py", line 19, in generate_image_thumbnail
    thumb_content = _create_image_thumbnail(field.path)
  File "/data/www/support.mozilla.com/kitsune/apps/upload/tasks.py", line 27, in _create_image_thumbnail
    originalImage = Image.open(file_path)
  File "/usr/lib64/python2.6/site-packages/PIL/Image.py", line 1952, in open
    fp = __builtin__.open(fp, "rb")
IOError: [Errno 2] No such file or directory
(Assignee)

Updated

8 years ago
Assignee: nobody → paulc
Target Milestone: 2.5 → 2011Q1
(Assignee)

Updated

8 years ago
Duplicate of this bug: 627476
(Assignee)

Updated

8 years ago
Whiteboard: [gallery]
(Assignee)

Comment 2

8 years ago
https://github.com/jsocol/kitsune/commit/904deaaab6e416c6326c30b0c89f43ee6d1cef18
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [gallery] → [gallery][qa-]
Target Milestone: 2011Q1 → 2.6
Closed as [qa-]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.