Closed Bug 624449 Opened 11 years ago Closed 11 years ago

Don't set displayport to cover never-to-be-defined pixels

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

defect
Not set
normal

Tracking

(fennec2.0+)

RESOLVED DUPLICATE of bug 624451
Tracking Status
fennec 2.0+ ---

People

(Reporter: cjones, Assigned: stechz)

References

Details

In the current code (last time I looked anyway), if you load a long page like http://www.timecube.com and then pan down, the displayport starts out covering pixels above the top of the document and to the left.  As you pan down, the size of rendered area increases as the displayport moves into defined pixels.  A similar effect happens when panning horizontally.

Not using available displayport area in this manner is bad for several reasons
 - (obviously) checkerboard earlier than should
 - resizing gfx buffers is rather expensive
 - happens on every page load, not in edge cases

We shouldn't ever set the displayport above or to the left of document <0, 0>.
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0+
Assignee: nobody → jones.chris.g
The WIP patch in bug 624451 fixes this.
Depends on: 624451
Sorry, same here, and stechz is working on it already.
Assignee: jones.chris.g → ben
One bug is enough
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624451
No longer depends on: 624451
You need to log in before you can comment on or make changes to this bug.