RSS 2.0 Feed uses xml tag guid instead of link to create the weblink

VERIFIED DUPLICATE of bug 541718

Status

Thunderbird
Message Reader UI
VERIFIED DUPLICATE of bug 541718
7 years ago
3 years ago

People

(Reporter: Joachim Moskalewski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

Example RSS XML file: http://www.heartofthewitch.eu/rss.xml?lang=en

Thunderbird uses the guid field instead of the link field to create the weblink to the full / original article. As such a weblink is of course unique, some blog hosters (f.e. LoveJournal) exports in both fields the same: the link to the article. But the guid field mustn't carry the weblink - therefore the link field is defined.

Reproducible: Always

Steps to Reproduce:
1. subscribe http://www.heartofthewitch.eu/rss.xml?lang=en
2. try to reach the website with the link thunderbird shows ...
Actual Results:  
unique identifier of an article as link

Expected Results:  
content of the link field as link
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 541718
Status: RESOLVED → VERIFIED

Comment 2

7 years ago
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 541718 ***

That bug has been fixed but this "duplicate" bug is still present in the latest Thunderbird release so I guess this bug is not a duplicate.
I really don't know why TB presents user with a "website: (guid value)" link when there is a "link" tag in the RSS feed that actually is a link to that article (and this link changes over time so it is not possible to be used as a guid value).
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> I really don't know why TB presents user with a "website: (guid value)" link
> when there is a "link" tag in the RSS feed that actually is a link to that
> article (and this link changes over time so it is not possible to be used as a
> guid value).

As far I understood bug 541718 the ID field is treated as an link as long as the attribute 'isPermaLink="false"' isn't set. Don't ask me why the hell someone should say that the ID isn't a link - to me it is logic that an ID isn't a link, and only if someone explicit tells 'isPermaLink="true"' it contains a link (but even that sounds strange to me - as there is a link tag to transport this information).

I've tried to find some official specifications on this and found none. So I changed the named RSS feed of my bug description to get thunderbird working (and actuall it doesn't work at all couse Livejournals rss feed is down).

Comment 4

7 years ago
The strange thing is, that even when I set the isPermaLink attribute to false, TB does not change its behavior. This must be a bug.

Comment 5

3 years ago
I had this problem (Thunderbird 31.1.2, Ubuntu 14.04) and setting isPermaLink="false" in the feed did solve the problem for me. Great!

But the default behaviour when isPermaLink is not specified (hypertext to <guid> instead of <link>) is weird.

Updated

3 years ago
Duplicate of this bug: 1189084
You need to log in before you can comment on or make changes to this bug.