Closed Bug 624614 Opened 11 years ago Closed 11 years ago

With 2 or more tabs with flash, closing one crashes Flash player

Categories

(Core :: Plug-ins, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 572134

People

(Reporter: cbarrett, Unassigned)

Details

Attachments

(2 files)

Attached file recursion? crash
STR:

1. Go to Youtube (but pretty much any site with Flash on it works)
2. Open two videos in two tabs
3. Let both of them play
4. Close one of the tabs with a video in it

Expected results:
The remaining tab keeps going

Actual results:
The remaining tab beachballs and then Flash crashes forcing me to reload the page. Sometimes it doesn't beachball at all.
This crash is less common than the above recursion crash, but I have several from today.

I can reproduce this pretty reliably -- maybe not 100% but definitely high 90%s.
Oh, and I'm using a 64-bit Firefox and Flash seems to be 32-bit. 10.6.6, but has been happening for weeks, months.
Attachment #502704 - Attachment mime type: application/octet-stream → text/plain
Attachment #502705 - Attachment mime type: application/octet-stream → text/plain
Per Damon's suggestion, moving to Core so I can nominate for blocking.
Component: Flash (Adobe) → Plug-ins
Product: Plugins → Core
QA Contact: adobe-flash → plugins
Version: unspecified → Trunk
blocking2.0: --- → ?
Don't ever file bugs in Plug-Ins. Ever.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 572134
Sorry bsmedberg -- will keep that in mind.
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.