Status

()

P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: edburns, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
The TH Browser doesn't have anything beneath it.  It should have some TD's beneath it.  Try loading this page in NS4.x and mozilla (buildid 1999050814):

http://java.sun.com/people/edburns/mozbug.html

Comment 1

20 years ago
Hmm. You have closed out the first row with a </TR> right after
'Engineering .. Frameworks .. Phone' in the 'Apps Groups' TH/Column.
So, Mozilla 5.0 seems to do things correctly.

What I can't see is why Nav4.5 _doesn't_ close out the same row.

  <TABLE BORDER>
    <TR>
      <td> (1,1) </td>
      <td> (1,2) </td>
      <td> (1,3) </TR>     <!-- why does 4.5 ignore this TR -->
      <td> (1,4) </td>
    </TR>
  </TABLE>

Comment 2

20 years ago
Created attachment 158 [details]
testcase; dubious [PP] -- ending table rows with </TR>
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

20 years ago
Egads. The </TR> is being ignored by 4.x. This is strictly incorrect, but I may
have to do it for backward compatibility.

Comment 4

20 years ago
BTW, IE 5.0 has the same behaviour (displays as a single row).

Which leads me to ask ... if Nav 4.5 and IE interpret this as a 1x4 table,
is it *me* who is out to lunch here (on the face of it, I think not, but it
seems like such a fundamental thing).
(Assignee)

Comment 5

20 years ago
Corrected by changes to parsing engine.

Comment 6

20 years ago
*** Bug 6990 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Status: RESOLVED → REOPENED

Comment 7

20 years ago
Bug #6990 pointed out that TH wants the same treatment as TD ;)
Tested with May23 viewer win95

  <table border>
  <tr>
    <th> foo </TR> </th>  <!-- Nav ignores this  /TR -->
    <th> bar </th>
    <th> bar
    <th> bar </th>
  </tr>
  </table>

Updated

20 years ago
QA Contact: 4144 → 4110
Resolution: FIXED → ---

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 8

20 years ago
Testing with 5/24 Apprunner, bug is fixed for <TD> and should be fixed for <TH>
with tomorrow's build. Will check tomorrow to verify.

Comment 9

20 years ago
Bug not fixed for <TH> in 5/25 build. Will try tomorrow.

Updated

20 years ago
Status: RESOLVED → REOPENED

Comment 10

20 years ago
Testing 6/3 with Apprunner, the bug is resolved for <TD> but not for
<TH>. Reopening bug.

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago

Updated

20 years ago
Status: RESOLVED → REOPENED

Updated

20 years ago
Resolution: FIXED → ---
(Assignee)

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

20 years ago
Sorry chris-- try it again -- the fix went in last night.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 12

20 years ago
Using 6/17 build, bug resolved for <td> and <th>. Verifying bug fixed.
You need to log in before you can comment on or make changes to this bug.