Get visited sites using getComputedStyle and CSS

RESOLVED DUPLICATE of bug 147777

Status

()

--
critical
RESOLVED DUPLICATE of bug 147777
8 years ago
8 years ago

People

(Reporter: simon.roesler, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.224 Safari/534.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

With using the Javascript code getComputedStyle and the CSS-Visited Tag it´s possible to check wheater an user has visited a specific website.
The Code to Check:
if(window.getComputedStyle(document.getElementById("check"),null).getPropertyValue("display") == "inline")

And the CSS for this:
div.history a { display: none;}
div.history a:visited { display: inline;}

Later I saw that it should already be fixed but it isn´t.

Reproducible: Always

Steps to Reproduce:
1. Visit a site
2. enter the site adress in the textbox at the included site
3. Click Check and see what happen
Actual Results:  
It says weather a site was visited or not.

Expected Results:  
There shouldn´t be an ability of checking this with javascript.

I read, that this is already solved but with my code (I don´t know what i did different) it´s working in my firefox.

Updated

8 years ago
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
Version: unspecified → 1.9.2 Branch
> I read, that this is already solved 

It's solved in Firefox 4.
(In reply to comment #1)
> It's solved in Firefox 4.

In bug 147777.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 147777
Group: core-security
You need to log in before you can comment on or make changes to this bug.