Star UI has no tooltip until bookmarked page is visited

RESOLVED FIXED in Firefox 4.0b10

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: neil, Assigned: Unfocused)

Tracking

({regression})

Trunk
Firefox 4.0b10
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [hardblocker][has patch])

Attachments

(1 attachment)

Reporter

Description

9 years ago
Steps to reproduce problem:
1. Set the home page to a page that is not bookmarked
2. Restart the browser
3. Note that the Star has no tooltip
4. Navigate to a bookmarked page
5. Note that the Star has a tooltip
6. Navigate to an unbookmarked page
7. Note that the Star has a tooltip

Expected result: Star tooltip at step 3 is the same as step 7.

There's a related version of this bug where visiting about:blank leaves the Star and its tooltip in its previous state.
Reporter

Comment 1

9 years ago
(In reply to comment #0)
> There's a related version of this bug where visiting about:blank leaves the
> Star and its tooltip in its previous state.
This is worse than I thought; simply opening a new tab triggers that bug...
Unowned blocker, over to Margaret.
Assignee: nobody → margaret.leibovic
Yoink!
Assignee: margaret.leibovic → bmcbride
Status: NEW → ASSIGNED
Keywords: regression
Whiteboard: [hardblocker]
[hardblocker] because it is a regression?  I'm not sure this should even be a blocker since it only involves a tooltip.
Posted patch Patch v1Splinter Review
Marco: You mentioned about maybe needing to special-case about:blank, but AFAICT that isn't needed. Or am I missing something?
Attachment #503397 - Flags: review?(mak77)
I was referring to the end of comment 0 and comment 1, but we don't show any star on about:blank. Neil, is that a specific Seamonkey problem? maybe you don't want the about:blank early return if you show the star, or you want to hide the star as well.
Reporter

Comment 7

9 years ago
(In reply to comment #6)
> I was referring to the end of comment 0 and comment 1, but we don't show any
> star on about:blank.
Ah, I hadn't realised you had extra CSS to hide stuff when the page proxy state is invalid (although in SeaMonkey, about:blank isn't an invalid page unless it's the first page in session history).
Attachment #503397 - Flags: review?(mak77) → review+
Flags: in-testsuite+
Flags: in-litmus-
Keywords: checkin-needed
Whiteboard: [hardblocker] → [hardblocker][has patch][needs landing]
https://hg.mozilla.org/mozilla-central/rev/2a6689064703
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [hardblocker][has patch][needs landing] → [hardblocker][has patch]
Target Milestone: --- → Firefox 4.0b10
You need to log in before you can comment on or make changes to this bug.