Failed to use 4.0b8 hung on home page google.co.uk

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Jim Joyce, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)
Build Identifier: Installed 4.0 beta 8 on Windows Xp

Now back on Firefox 3.6 13.
Installed 4.0 b8, but after numerous attempts (including rebooting) to load FF,
deleted 4.0 and re-used 3.6 (It was still present in 'Program Files' but in a different folder. 
I noted there were more files with TODAY'S date in the 3.6 folder, than there were in the 4.0 folder !!! And they're still there.
4.0 hung with the Google.co.uk page visible, but with the GREEN loading-circle 
continually rotating in the top left tab. It was using a fair bit of CPU processing time.

Reproducible: Always

Steps to Reproduce:
1. Make goog;e.co.uk my home page
2. Re-install 4.0
3. Run firefox 4.0
4. Google page loads
5. Wait for ever
Actual Results:  
Tried step 3 again and again.
Sometimes killing 4.0, then running 3.6.
3.6 worked OK.
Killed 3.6, retried 4.0

Expected Results:  
Should have loaded an active google page
(Reporter)

Updated

7 years ago
Severity: minor → normal
Please try http://support.mozilla.com/en-US/kb/Safe+Mode and be sure that you don't have a stupid third party Firewall that blocks the different Firefox version in a different directory
(Reporter)

Comment 2

7 years ago
I'm using Norton Internet Security, with Firewall Protection ON.
No special settings.
I admit I was surprised to find that Firefox 4.0 gave itself a new folder in Program Files. That may be my trouble.
Problem is: If I delete my original 3.6 folder, and then 4.0 still fails to work,
I cannot recover FF3.6.
I'll try copying FF3.6 to a separate hard drive, then give FF4.0 a go.
(Reporter)

Comment 3

7 years ago
Tried all that. NO BETTER.
After moving FF3.6, I found the FF4.0 folder empty except for an empty 'Components' folder.
I deleted 'components' and downloaded FF4.0b8 and re-installed.
I'm back on FF3.6 
I should also add that I'm unable to simply close down FF4.0.
It's so busy it won't accept an interrupt.
I'm using TaskMaster to kill it.
(Reporter)

Comment 4

7 years ago
Read your Help again.
This time noticed the bit about Safe-Mode.
In SafeMode I disabled add-ons.
SUCCESS
I'm now in FF4.0 (SM) and it's working OK.
I'm sure I'll manage without the Add-Ons.
Thanks for your help.
The safemode is doing 3 things: It disables all Addons the JIT and the graphic hardware acceleration. It's unlikely that the jit is the cause of your problem.

As first step disable all addons in tools/addons/extensions and restart in the normal mode. It's an addon problem if it works now. Enable the addons one by one to find the addon that is causing your problem.

Comment 6

7 years ago
Jim -> Did you find the addon at fault?
Version: unspecified → Trunk

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Resolution: --- → INVALID
(Reporter)

Comment 7

7 years ago
Sorry, I've been rather busy for a while.
When I'm online, I've disabled add-ons.
Will try to tackle the progressive loading soon.
Thanks, and Sorry, again.
(Reporter)

Comment 8

7 years ago
I decided I owe it to you to make some attempt to test those add-ons.
I got a shock. I looked at Tools/Add-ons and found I had 39 Extensions, 1 Appearance
and 12 Plugins. I don't need half of them - Do I need any? I ask myself ! ! !
I'm listing them all below.
I've marked with an asterisk the Extensions which are flagged as incompatible with Firefox 4.0b10
Of those, I would like to re-instate Firebug, CSS Validator, HTML Validator, SVG-edit and perhaps Gmail Notifier - and I'm not aware that I have used any of them.

Would you like me to add those five, one by one, t0 Firefox 4.0b8 ?? 

EXTENSIONS

* Animat 11.08
* APNG Edit 1.5
* Better Gmail 2 1.2
* Broadband Speed Test & Diad=gnostics 1.2.5
* CSS Validator 3.0.0
* CSS Viewer 1.0.3
  Domain Details 2.6.8
  Download Accelerator Plus (DAP) 9.5.0.0
  Download Helper 4.8.2
  EditCSS 0.3.7
* FastestFox 4.1.8
  Feedback 1.0.4
* Firebug 1.6.1
* FireFTP 1.0.10
  FireGPG 0.8
  Ghostery 2.4.2
* Gmail Manager 0.6.1
* Gmail Notifier 0.6.4.3
  Greasemonkey 0.9.1
* HTML Validator 0.8.6.1
  IE View 1.4.5.1
  Java Quick Starter 1.0
* Javascript Debugger 0.9.88.1
* JSView 2.0.5
* MadSwatter 0.9.1
  McAfee SiteAdvisor
* Microsoft.NET Framework Assistant 1.2.1
* Microsoft Default Manager 2.1
  Minimap Addon 0.3.13
  Norton IPS 2.0
* Norton Toolbar 5.5
  OperaView 0.7
* Page Validator 3.0.0
* SVG-edit 2.3.0.1
* Tab Mix Plus 0.3.8.4
* View Source Choice 0.5
  Web Developer 1.1.9
  WiseStamp 2.0.5
* Yahoo Toolbar 2.1.3 20200310105313

APPEARANCE

* Default 4.0b10

PLUGINS

  Adobe Acrobat 9.4.1.222
  Cortona3d Viewer 6.0.0.179
  Google Earth Plugin 1.0.0.1
  Google Update 1.2.183.39
  Java Deployment Toolkit 6.0.220.4
  Java(TM) Platform SE U22 6.0.220.4
  Microsoft@ DRM 9.0.0.4503
  Quicktime Plugin 7.6.7.0
  Shockwave Flash 10.1.102.64
  Silverlight Plug-In 4.0.51204.0
  Windows Media Player Plug-in Dynamic Link Library 3.0.2.629
  Windows Presentation Foundation 3.5.30729.1

Comment 9

7 years ago
The fewer addons you use, the faster Firefox will be to start up, the less RAM it will use and the less likely you will inadvertently be using an incompatible addons. As such, less is normally "more" when it comes to addons.

If you wish to find out the problematic addon I would suggest say enabling 5-10 addons at a time to speed things up (restarting Firefox inbetween for the change to take effect), to gradually narrow down which one is causing the problem.

If you do find out the cause, please post back with the addon name and version, since it can help with any future blocklisting decisions.

Btw I would start with testing the McAfee Site Advisor extension, since that is known to cause problems.
You need to log in before you can comment on or make changes to this bug.